Page MenuHome

Numpad problems in laptop
Closed, ArchivedPublic

Description

System Information
Windows 10 64bit
ASUS ROG Zephyrus GX501

Blender Version
Broken: Blender 2.79 b5b5260

Short description of error

My laptop has an option for turning the trackpad into a numpad with the push of a button, it's quite clever and nice for Blender. However for some reason it's not behaving properly in Blender, at least anything related to combining a numpad key with a modifier key is failing.

Exact steps for others to reproduce the error

I have recorded this video to show the problem.
https://www.youtube.com/watch?v=9PREa_n_ffQ

Details

Type
Bug

Event Timeline

Dont have such hardware at hand.
So these combinations of numpad + modifierkey dont show up when you launch with --debug-events?

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Apr 19 2018, 9:51 PM

Also: could you confirm such a key-combination is working properly in any other software?
(cant think of a good example, but e.g. in a text editor like atom.io... I think you get what I mean?)

Marking as incomplete until we have those questions out of the way

Thank you for taking the time. This is what I get with --debug-events from a single Ctrl+ operation (select more in edit mode):

In fancy laptop (Only results in zoom operation):

wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:1 / PRESS,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(648,514), ascii:' ', utf8:'', keymap_idname:(null), pointer:0000019A97C05B88

wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(648,514), ascii:' ', utf8:'', keymap_idname:(null), pointer:0000019A97C06BD8

wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:1 / PRESS,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(648,514), ascii:'+', utf8:'+', keymap_idname:(null), pointer:0000019A97C06C68
wm_handlers_do_intern:       handled! 'VIEW3D_OT_zoom'

wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(648,514), ascii:' ', utf8:'', keymap_idname:(null), pointer:0000019A97C05B88

In Linux box with regular keyboard (It works correctly)

wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:1 / PRESS,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(897,442), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7f8e6498a988
 
wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:1 / PRESS,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(897,442), ascii:'+', utf8:'+', keymap_idname:(null), pointer:0x7f8e6498a988
 
wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:2 / RELEASE,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(897,442), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7f8e6498a988
 
wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(897,442), ascii:'', utf8:'', keymap_idname:(null), pointer:0x7f8e6498a988

Fancy Laptop but with an USB keyboard hooked into it (It works!)

wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:1 / PRESS,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(744,469), ascii:' ', utf8:'', keymap_idname:(null), pointer:000001F20A175E08

wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:1 / PRESS,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(744,469), ascii:' ', utf8:'', keymap_idname:(null), pointer:000001F20A177AB8
wm_handlers_do_intern:       handled! 'MESH_OT_select_more'

wm_event_do_handlers: Handling event
wmEvent  type:164 / NUMPAD_PLUS, val:2 / RELEASE,
         shift:0, ctrl:1, alt:0, oskey:0, keymodifier:0,
         mouse:(744,469), ascii:' ', utf8:'', keymap_idname:(null), pointer:000001F20A179BE8

wm_event_do_handlers: Handling event
wmEvent  type:212 / LEFT_CTRL, val:2 / RELEASE,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(744,469), ascii:' ', utf8:'', keymap_idname:(null), pointer:000001F20A178208

As for the other part of the question. I tried on Inkscape and you're right, it doesn't work there either! So I guess this is not a Blender specific bug after all. In any case, do you see any difference in the debug prints?

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.May 1 2018, 8:10 AM

Hi, seems like it is sending a release before any other press [akward... so no simultanious presses], but as this seems to be a general issue with that hardware, I dare archiving this.
Have you tried reporting this to the manufacturer?

Feeld free to reopen when this is working alsewhere (but not in blender)

Philipp Oeser (lichtwerk) closed this task as Archived.May 2 2018, 9:30 AM
Philipp Oeser (lichtwerk) claimed this task.