Page MenuHome

Navigate Manipulator overlapped by properties when region overlap on
Closed, InvalidPublic

Description

System Information
Windows 10 Pro 64 Bit, GeForce GTX 675M

Blender Version
Branch blender2.8 (2.80.5), Hash:-cca1e1b, Date: 2018-03-15 16:36, win64-vc14

Short description of error
When the Navigate Manipulator is activated in the user preferences (Interface), as well as the Region Overlap (System), then the Navigate Manipulator will be overlapped by the properties region. If the region is transparent, the Navigate Manipulator buttons still get highlighted, but don't capture mouse input. I think this goes against the core design principle of everything being non-overlapping and accessible.

Exact steps for others to reproduce the error

  • Have the 3DView visible.
  • Open User Preferences
  • under Interface check Navigate Manipulator
  • under System check Region Overlap
  • In the 3DView show the Properties Region (press N, or View->Properties)

Suggestion
Anchor the Navigate Manipulator to the left region (Properties), just like the Mini Axis is anchored to the right region (Tool Shelf).
I believe there was a way to switch positions of properties and tool shelf in blender, so one might watch out for that when fixing the bug.

Details

Type
Bug

Event Timeline

The mention of »UV/Image Editor: Optimize UV Drawing« was accidental, because of the blender build hash. I don't know how to get rid of it.

LazyDodo (LazyDodo) closed this task as Invalid.
LazyDodo (LazyDodo) claimed this task.

Thank you for the report. Currently we are aware of many issues in 2.8 and actively working to fix them. But since replying to reports takes time, we have decided to limit bug reports to module team members.