Page MenuHome

OBJ import - same named .obj entries are appended to one mesh / not extra objects
Closed, ArchivedPublic

Description

System Information
any sys, any card

Blender Version
Broken: blender-2.79.0-git.0301df4 also official 2.79a
Worked: I don't think so

Importing example file problem.obj does not result in different objects

Exact steps for others to reproduce the error

  • open default scene, remove all
  • import probem.obj with options:
    • split: checked "Objects", checked "Keep Vert Order"
  • result: one object in blender with 4 screw meshes

--> should be individual objects, like

this is just to show/clarify the problem:

  • import problem_edit.obj (which was edited in text editor to unique named "g ......" lines
  • result: invdidual objects (as there are invdividual names)

same named .obj objects should not be inside one mesh

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) closed this task as Archived.Mar 19 2018, 4:35 PM
LazyDodo (LazyDodo) claimed this task.
  1. the .obj specifications are rather vague and do not mention what is supposed to happen with duplicate names.
  2. ue4 does the same thing with these files.

So this i'd have to classify this as a feature request and not a bug. while we love to hear feature requests, this is not the right place for them. This website is mainly used to track bug reports and not feature requests. But there are some other nice solutions you can take, so please use one of the other forms of communication listed below:

https://rightclickselect.com/
Fun board mailing list: https://lists.blender.org/mailman/listinfo/bf-funboard

I'd say this is not a bug.
The same group name can apparently be reused, and refers to the same group.

At least that's what this spec seems to imply: http://www.martinreddy.net/gfx/3d/OBJ.spec
See the example "Cube with group names", it states that "all elements belong to the group cube". And the g statement is used multiple times.

However it might be worth considering to split even with the same name as a work around. But I guess this is rather a bug in the exporter.