Failed to load kernel path init on Linux
Closed, ResolvedPublic

Description

  1. Bug report on Blender-edge and Blender 2.8

CPU only render: no issues, all threads used.
CPU OpenCl render: no issues, only one thread used.
GPU OpenCl render: Failed to load kernel path init.
CPU & GPU OpenCl render: Failed to load kernel path init.

  1. Bug report on Blender 2.79b

CPU only render: no issues, all threads used.
CPU OpenCl render: not available.
GPU OpenCl render: no issues.
CPU & GPU OpenCl render: not available.

LinuxMint 18.3 Cinnamon (Ubuntu 16.4.3) Kernel 4.13.0-37
Intel i7 965E, AMD R9-380x, 16GbRAM, 2x120Gb SSD-RAID0

Joel Mativet (EmJay) updated the task description. (Show Details)
Brecht Van Lommel (brecht) triaged this task as Incomplete priority.

Please mention the exact version number you test, including the hash from the splash screen. We do not support CPU rendering with OpenCL, there is no point since we can natively render on the CPU. Combined CPU + GPU rendering is not yet available in any official release, so it's not in 2.79b.

We do not handle bug reports for third party builds like the blender-edge package. Please try the official master and 2.8 daily builds from here and see if the issue still happens:
https://builder.blender.org/download

If the problem remains, start Blender from the command line with --debug-cycles flags, and attach the log to this report so we can get a precise error message.

Hiya Brecht,
Sorry, I didn't know that CPU+GPU wasn't yet available in 2.79b.
Didn't know either that Blender-Edge wasn't yours.
Thus my surprise to find that CPU+GPU is available in Blender edge and not in 2.79b...
Got that.

In regards to 2.8:
Date: 2018-03-23 15:35
Hash: 0c753cldc4
Branch: Blender2.8

See attached log{F2534563}

Cheers

EmJay

Thanks for the log, the fix will soon be in the various builds.

Thanx a million Brecht
Cheers!
Have a Merry and Happy Easter!!

Hi Brecht,

this seems to be again up with current Buildbot: 0bf8096501a
Using Windows 10 / 64 Bit. Radeon Drivers 18.6.1
RX 480 / 580

failed to load kernel_path_init.

BMW Testfile.

Cheers!