Page MenuHome

Color Picker in Texture Nodes defaults to first view transform
Closed, ArchivedPublic

Description

System Information
Debian Testing

Blender Version
Broken: master

Short description of error
Blender defaults to the first view transform when attempting to invert the transform for picking colours. This is making it very challenging attempting to implement a proper wide gamut set for Blender for a number of reasons:

  • Not all transforms are invertible. Blender shouldn't be relying on view transform inversion to select colours. Instead, a buffer should be provided in reference, and the selection should be made from that, not relying on the invertibility of a particular transform.
  • The current design handcuffs placing a display referred transform in the default view position. This may be confusing for some individuals, forcing them to manually change the view to the correct view. The proper approach would be to use the role for texture painting or color picking here, depending on location of the particular picker.

Exact steps for others to reproduce the error

  1. Open texture node editor.
  2. Pick a colour with a configuration that doesn't list a pure 2.2 or sRGB OETF transform as the default view.

Values will be broken.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Hi @Troy Sobotka (sobotka), noticed this has been unanswered for quit some time.
Issue adds up to already existing T41287.

Since colormanagement is not my playground, I would kindly ask @Sergey Sharybin (sergey) to have a look.

Sergey Sharybin (sergey) closed this task as Archived.Apr 18 2018, 10:27 AM

Not only this issue is already reported, system behaves according to its current design.

Surely, it might not meet your expectations, but technically it is not a bug and is to be handled outside of the bug tracking system.

Thanks for the report anyway.

This is a different issue regarding transformation order, but alas.