Page MenuHome

External data unpack error. Same file works with current dir method, and not with original location method.
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Windows 7 64 bit, GTX 1060

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Same file. A hdri. With export method current directory the export works fine. With original location the export fails.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Open attached Blend file. Unpack textures with method original location. You will get an error. Unpack textures with method current directory extracts the same file just fine, in a folder called textures.

What is completely confusing here is how the unpack works. Current directory creates a sub folder called textures. And does not extract into the current directory. And nothing can convince Blender then to use textures that are placed besides the blend file. Paths are now nailed to the textures folder. At least i haven't found a way. Make textures relative doesn't do anything.

Original location extracts into the current directory, besides the blend file. And not into the original location. The original location would be the absolute path in the error message. The drive exists, and the label promises me that it gets created when necessary. But the other two textures gets extracted into the current location, most probably since they were relative before packing. Well, here the original location may fit.

What i miss here is a relative extraction method that does not use a textures folder. And i can still not say what method is now the correct one. I am simply confused how it is expected to work. Shouldn't all packed data be relative to the archive?

Trouble file:

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Apr 9 2018, 3:11 PM

Unpack textures with method original location. You will get an error.

In case of the HDRI, this is the main error we have to investigate here

Unpack textures with method current directory extracts the same file just fine, in a folder called textures.

true, intended behaviour

What is completely confusing here is how the unpack works. Current directory creates a sub folder called textures. And does not extract into the current directory. And nothing can convince Blender then to use textures that are placed besides the blend file. Paths are now nailed to the textures folder. At least i haven't found a way. Make textures relative doesn't do anything.

The fact that blender groups unpacked data in 'proper' subfolders is documented in the manual.
If you have the files sitting directly in the folder of you current .blend and don't want to use the ones in the 'textures' subfolder, you can just remove the 'textures' subfolder (making the paths invalid) and use the File > External Data > Find Missing Files operator [just point it to the directory of your current .blend and it will fix all the paths to the files found in there]

Original location extracts into the current directory, besides the blend file. And not into the original location. The original location would be the absolute path in the error message. The drive exists, and the label promises me that it gets created when necessary. But the other two textures gets extracted into the current location, most probably since they were relative before packing. Well, here the original location may fit.

Well yeah, for the relative textures it just works fine as you observed correctly, we still have to find out why blender cant create the hdri in the absolute file path. You were saying the drive exists, can you actually create that folder / save a file from within blender there?

What i miss here is a relative extraction method that does not use a textures folder. And i can still not say what method is now the correct one. I am simply confused how it is expected to work. Shouldn't all packed data be relative to the archive?

Afaik the "Current Directory" method that doesnt use the subfolders doesnt exist ["Original Location" it works though -- well only if blender can actually write that file...]

Can you/blender actually write in the path of the HDRI? Could it be a (write)permission thing?
Marking as incomplete until we know why blender cant write that HDRI in the original location. If there are still questions remaining we can continue after that question is out of the way...

Thanks for explanation. Seems that i have to live with the current behaviour.

And now i see the problem. D: is my dvd drive. And not accessible, since i have no dvd in the drive. The file comes from an external source. And i guess he had this hdri folder in this path at D. Maybe at a dvd ...

Philipp Oeser (lichtwerk) closed this task as Resolved.Apr 10 2018, 9:18 AM
Philipp Oeser (lichtwerk) claimed this task.

OK, I think we can close this then