Page MenuHome

Blender Running Laggy and Slow, Almost Unusable
Closed, ArchivedPublic

Description

System Information
Windows 10
GTX 1080 Updated Drivers 391.35
Intel i7 4.0 GHZ processor
2 500GB SSDs
16 GB RAM

Blender Version
Broken: 2.79b
Worked: never

Whenever I run blender, the entire application runs incredibly slowly and laggy, getting worse if more objects are on screen (about 5-0.5 fps). The application seems to cap out at 6 GB of RAM constantly, but barely uses above 20% of my processor. It does not slow down my computer at all, just blender runs slowly.

I have tried changing the draw method in system settings. It allowed it to run a little bit better, but still terribly laggy, and it caused an issue making the UI glitchy and almost unusable. I have read online that running blender with integrated graphics can help, but my computer does not have an integrated graphic card, only a dedicated one.

Exact steps for others to reproduce the error
Any time running Blender

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) triaged this task as Needs Information from User priority.

Is this with the standard cube or with a very large scene?

This occurs with a standard cube (about 2-5 fps). If I load in a character model it gets even worse( below 1 fps)

Let's see what graphics card blender is using on your computer.
In the Help tab click on Save System Info and then share the file generated here. (Maybe that gives some clue of what's going on).
Another thing that would help investigate would be by opening blender from the Command Prompt adding the arguments --debug-gpu. The prompt will display some information that may be useful.

Alright, I've attached the file and I will look at the information displayed from the debugging, thank you.

Looks like you're running on mesa? did you by any chance drop a opengl32.dll in your blender folder?

I don't believe so, I've been having this problem since I first download blender yesterday, I'll check if I can find that file.

Woah, I found the file you were talking about and removed it. Everything seems to be running fine now. I have no idea how that file was in there if it was not supposed to be.

Thanks for all of your help!

LazyDodo (LazyDodo) closed this task as Archived.Apr 12 2018, 5:36 AM
LazyDodo (LazyDodo) claimed this task.

waooo thanks so much this information worked for me too..... my blender is now working fine and faster

Looks like you're running on mesa? did you by any chance drop a opengl32.dll in your blender folder?

That's what I did, although I didn't have much of a choice. Blender won't run without it. I copied it from my JKA game, if that helps.

If you drop in an software opengl implementation, things are gonna be slow, If blender doesn't run without it you either have an old video card, or have driver issues.

Todd Robert Vander Galien (ToddVG) removed LazyDodo (LazyDodo) as the assignee of this task.
Todd Robert Vander Galien (ToddVG) raised the priority of this task from Needs Information from User to Unbreak Now!.

I am having the same issue, but can’t find any file added file mentioned above.

I am just now getting involved in this photogrammetry and as we know the files are quit large. I am importing an .OBJ file from Meshroom and from the import to any other click there is lag.

Being new I am trying everything to speed it up, I thought deleting large parts of the file would help, but there is no clear way that I can delete from my import. I would like to speed this process up.

TWO QUESTIONS

1- Please what is the easiest way to delete a large amount of data from the image? (example = counter top around a coffee cup. Or maybe grass around a concrete pad that has a statue on it. Or part of a cloud that was mistakenly brought into the photogrammetry process?

2- SPEED.. baby SPEED. “ I am using the process B to choose area then X to delete vertex, I rotate around to make sure to get as much as I can but with the lag there is 5-10 sec wait between clicks.

Please help