Page MenuHome

Slow startup with userpref.blend file on 2.79b
Closed, ArchivedPublic

Description

System Information
Windows 8.1
Intel core i5 4770, Intel HD Graphics 4600

Blender Version
Broken: 2.79b (MSI installed version)
Worked: 2.79b (zip), 2.79a (both iMSI and zip)

When launching blender 2.79b, the blank console window pauses for several seconds before finally indicating that the prefs have been loaded and displaying the main blender window. This only happens when a userpref.blend file exists. Only the MSI installed version seems affected. The portable/zip version doesn't seem to be affected. The same behaviour occurs whether the prefs file is old (created by a previous version of blender) or fresh (created in 2.79b without any settings touched).

Exact steps for others to reproduce the error

  1. Launch blender without any userpref.blend file in the config folder. Blender launches quickly (i.e. at it's normal speed). The console window is only visible for less than 1 second.
  1. Go into the user preferences menu and click the "Save User Preferences" button to create a new userpref.blend file. Don't change any settings prior to saving (so the prefs file will be "clean" with presumably default settings).
  1. Exit blender and re-launch
  1. The blank console window is displayed for about 4-5 seconds before the message appears indicating that the prefs have been loaded. The main blender window then appears.

Details

Type
Bug

Event Timeline

No idea, both the .zip and .msi are packaged from the same binaries, there's not even a recompile there so the behavior should be identical between the two.

Sebastian Parborg (zeddb) closed this task as Archived.Wed, Feb 6, 4:19 PM
Sebastian Parborg (zeddb) claimed this task.

@Aaron Corey (aarondrew) If you can't reproduce this with the .zip builds, there is not much we can do.