Page MenuHome

Overhaul Mesh bind modifier
Closed, ArchivedPublic

Description

Currently there are a number of small feature options that could improve the mesh deform modifier,

  1. Progress Bar - So you can tell if the bind has stalled do to lack of resources or if it will take 2 days etc.
  1. Radius option - use BVHTREE acceleration to limit calculations based on distance from cage vertex bvhtree.find_nearest_range()
  1. falloff weighting - in vertex hook modifier we have falloff options, can be useful for complex meshes and realtistic looking deformations

Thanks
Jacob Merrill

Details

Type
To Do

Event Timeline

Aaron Carlisle (Blendify) closed this task as Archived.
Aaron Carlisle (Blendify) claimed this task.

Thanks for the report but making tasks like this is not useful unless you or someone else is willing to work on them. In that case, just send a patch when done. In the meantime I am closing this.

@Brecht Van Lommel (brecht) told me to open this

"I agree it would be good to have a progress bar here, but that's a To Do list item, not a bug to be handled in this tracker."

Ideasman42 said using the patch - https://developer.blender.org/rBS984e9f9cc8eee131c6602b326e588d2903eda90a - is a good idea, we already almost have the guts to use bvhtree find_nearest_range()

and falloff is just something that seems like it could be handy.

Ok we can re-open then

LazyDodo (LazyDodo) closed this task as Archived.

You misunderstood brecht a tiny bit there, we don't track todo's/feature requests on this tracker, hence he told you not to post it here. there's also this warning in the report a bug page to discourage people from doing it anyway.

What not to report here
Feature requests, see the developer contact page.
Items that are already on our To Do list.
Compile or build issues, ask on #blendercoders or mail bf-committers.

closing again.

I want to code it* I need guidance though as this is not my specialty (I code py mostly)

I noted the bottleneck with bind doing some production work and want to fix it.

this patch already builds the bvhtree (for other reasons)

basically we are just limiting the vertex considered by each cage vertex using the bvhtree find_nearest_range()

https://developer.blender.org/rBS984e9f9cc8eee131c6602b326e588d2903eda90a

I could also use guidance on invoking the progress bar (should I look at image baking or something?)

LazyDodo (LazyDodo) added a comment.EditedApr 16 2018, 8:40 PM

that may well be, but that doesn't mean it belongs on the bug tracker, you may be better served on https://devtalk.blender.org/

however, before you blindly cut/paste this text on there, at this point in time this looks like a plain and simple feature request, which isn't allowed on devtalk either. so if you do decide to open a post there, please ask specific questions. What have you tried, where are you stuck? what is preventing you from fixing it your self? you keep posting this commit, so you surely have found the relevant code, go play with it? run it though the debugger, make some changes!

I see, I am setting up a build environment now on my new pc,

I was really trying to go through the proper channels so the patch is expected and accepted.

I do have some questions though - I should keep the static int intersection method right? (the bvhtree ray version ended up having issues or did I misunderstand this?)

I redirected you the right place to ask the developers questions/guidance, the bug tracker is not it, please try to avoid using is like that