Page MenuHome

Poor shadow smooth when using bump
Closed, ArchivedPublic

Description

System Information
Windows 10 and Geforce 1070

Blender Version
2.79a

Short description of error

When applying bump map to the material, the shadows are no longer smooth. they loose quality.

A workaround is to set the lights size to 1, at least. But for using HDRI, i don't know what to do..

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Archived.Apr 17 2018, 1:02 PM
Philipp Oeser (lichtwerk) claimed this task.

I believe this is caused by an extreme value for bump (causing the normals to point in all kinds of directions). Or I'll quote @Brecht Van Lommel (brecht) from T54498:

In general such artifacts can happen if the normals are too different from the actual geometry, and the low poly geometry reveals itself

another quote from there:

It's another case of the terminator problem. We have some work towards improving it in D2574 but there's no easy solutions in general.

As a workaround you can lower the value of your multiply node, or better in this case use True displacement / Adaptive Subdivision, see the manual

I dare archiving this as known limitation, unless @Brecht Van Lommel (brecht) has something to add?