Page MenuHome

Corner Pin adds blur to an input image?
Closed, ArchivedPublic

Description

The Corner Pin node seems to distort the edges of shapes, even when applied in such a way that should cause no change. In the screengrab attached, the background shows the difference between the input (the alpha layer of a png), and the same image fed through a Corner Pin node with no distortion. I would expect there to be no difference. Is there a reason why there is a difference, or is this a bug?

This happens with any image, with or without alpha, and not just when working with pngs. I just happened to notice it when dealing with alpha layers, because it tends to add a halo. (There are no Alpha Overs involved, so this is unrelated to premultiplying behavior.)

Other Distort nodes, like Translate, Tansform, Scale, Rotate, etc., don't create these edges when they have "identity" settings that you'd expect would have no change. This has only been observed with Corner Pin.

Details

Type
Bug

Event Timeline

It might be an offset or something, rather than a blur. Using a Subtract node instead of a Difference node to compare the input and output shows result that suggest this:

Yeah, there is some blurring at the default values.
Assume that the image is recalculated (always) which leads to blurring.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 11 2019, 12:11 PM

Can you attach a simple .blend with that setup? Don't forget to pack the image.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.Feb 11 2019, 12:42 PM

There are artifacts with the default settings as corner pinning uses EWA filtering. At this moment we don't have the capability to configure what filtering to use. EWA filtering is selected as it gives better result in normal use cases.

Jeroen Bakker (jbakker) closed this task as Archived.Mar 19 2019, 4:37 PM

Archiving this issue as it is not a bug. Questions and possible future improvements etc should go to the proper channels.