Page MenuHome

Modifiers: Convert from DerivedMesh → Mesh
Closed, ResolvedPublic

Description

Take D3155 and transform some simple deforming and constructing modifiers to use Mesh instead of DerivedMesh.

Work was done on the temp-modifier-rm-cddm branch, and is now done on blender2.8 directly.

Ported are:

Details

Type
To Do

Event Timeline

Sybren A. Stüvel (sybren) moved this task from Tasks to Doing on the Code Quest board.
Sybren A. Stüvel (sybren) triaged this task as Normal priority.

D3155 has been merged with the blender2.8 branch.

@Sybren A. Stüvel (sybren): ParticleInstance modifier got a little, now ready to port

Sybren A. Stüvel (sybren) updated the task description. (Show Details)
Sybren A. Stüvel (sybren) raised the priority of this task from Normal to Confirmed, High.
Brecht Van Lommel (brecht) lowered the priority of this task from Confirmed, High to Normal.Aug 13 2018, 11:39 AM
Campbell Barton (campbellbarton) closed this task as Resolved.

Closing this task because all modifiers except for subsurf have been converted.

Subsurf is a bigger task which doesn't benefit from this being kept open. See: T57239