Hair Clumping Error
Closed, ArchivedPublic

Description

System Information
Mac OS Sierra 10.12.6 with Intel HD Graphics 6000

Blender Version
Broken: 2.79b f4dc9f9

Short description of error
The error with the hair particle system involves the clumping editor. In Blender versions of Windows,the hair particles are clean and behave like Example #1. However,for Mac OS,it's a whole different story. Instead of the slider behaving like it should,it makes the hair clump incorrectly like in Example #2. This really bothers me and I think it should be fixed.

#1

#2

Exact steps for others to reproduce the error
To fix the error presented in the file below,I would suggest fixing the coding of the hair particle system.

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Apr 24 2018, 10:32 AM

Are you sure you are examining the same files in Windows/Linux compared to MacOS?

Because when I open provided file on Linux, I get the same result as posted in picture #2.

The reason for some of the child particles appearing shorter than the parent particles is the Length ("length of child paths")

This was set to 0.8 in your file, and the threshold of 0.1 was causing 10% of the children being full length, the remaining 90% were only 0.8times as long as the parent particles.

If I set the Length back to 1.0 I get a result as posted in picture #1.

Is that what you meant?

Marking as incomplete for the time being...

Oh,my God! I just realized that I made a mistake. I replaced the top screenshot with the correct one and I corrected the versions of Blender. Sorry for the inconvenience.

This might have been fixed since then (there were some threading issues in particle code), please check with a blender2.8 alpha build.

Bastien Montagne (mont29) closed this task as Archived.Jul 25 2018, 9:33 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.