Page MenuHome

Velocity doesn't work in Edit Object Actuator, Add Object in Blender Game Engine
Closed, ResolvedPublic

Description

System Information
Windows 10, 64-bit, Intel graphics on HP Stream

Blender Version
Broken: 2.79

Short description of error
Starting velocity of newly added objects at non-zero, they still don't go anywhere when added using the Edit Object actuator Add Object option, in Blender Game Engine. All linear and angular velocity dimensions tested.

Additionally, object appears at wrong scale. Perhaps because of scale of source or added object.

Exact steps for others to reproduce the error

  1. Start game engine.
  2. Left click on worm gear.

worm gear.001 appears to get added, however without specified velocity.

Additionally, worm gear.001 gets added at far larger size. Both worm gear meshes should be the same size, one is simply a duplicate of the other. Each has scale (XYZ) 3, and it looks like maybe the added mesh is getting scaled three times original mesh AND three times that, for 9x scale instead of 3.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Resolved.May 2 2018, 12:55 PM
Philipp Oeser (lichtwerk) claimed this task.
  • You have to make sure your spawned object has a Dynamic Physics type, (see the manual), also see stackexchange here
  • Yes, object scale of original object gets multiplied, so if you apply scale on Tooblet.Worm Gear it should behave as expected.

Triaging as Resolved now (feel free to reopen if you think you found a bug)