NodeGroup input doesn't work when unconnected in Eevee renderer. (Also Cycles to a degree)
Closed, ArchivedPublic

Description

System Information
Windows 10 Home 64, with NVIDIA GeForce 940MX

Blender Version
Broken: 2.8 c21ceb3 (win64-vc14) and 5dab34d (win64-vc14)

Description
Like it says in the title when a NodeGroup has an unconnected socket, the textbox/slider/color selector for that socket won't work in Eevee renderer.

Exact steps for others to reproduce the error
In a new file (default cube):

  • Assign a new material to the default cube.
  • Set shading to "Rendered".
  • Switch to Node Editor (this is easier to notice if the window is split to keep a 3D View open.)
  • Select Principled BSDF in Node Editor, and group it (Ctrl-G). This is simply an example, but from my experience, this happens with every NodeGroup.
  • The values assigned in the textboxes, sliders and color boxes of the NodeGroup won't have any effect on the rendering anymore.
  • If a Value Node or RGB Node is connected to them, and then used to change the parameter, everything works fine, but as soon as they're disconnected, it stops working again.
  • This happens in Eevee renderer, but a very similar issue happens in Cycles, where the renderer won't update material parameters until the user switches to another renderer, and back to Cycles. In this case, the NodeGroup inputs work, but only after switching renderer.

Details

Type
Bug
Philipp Oeser (lichtwerk) closed this task as Archived.May 2 2018, 12:14 PM
Philipp Oeser (lichtwerk) claimed this task.

I can confirm the described behaviour.
However 2.8 is still WIP in many areas.

Raising awareness with @Sergey Sharybin (sergey) and @Clément Foucault (fclem) (but I am pretty sure this is a known issue atm.)

Have to archive this due to our tracker policy on 2.8:

Thank you for the report. Currently we are aware of many issues in 2.8 and actively working to fix them. But since replying to reports takes time, we have decided to limit bug reports to module team members.

Thank you! I tried looking for this issue everywhere and couldn't find anything. I won't report any more 2.8 issues for now then!

Olivier