Animating a chain of bones with Auto IK enabled will not record during Playback+Automatic Keyframe Insertion
Closed, ArchivedPublic

Description

System Information
Windows 7 64bit and Nvidia GTX 970

Blender Version
Broken: 2.79b f4dc9f9d68b

Short description of error
Animating a chain of bones with Auto IK enabled will not record during Playback (Automatic Keyframe Insertion during Playback)

Exact steps for others to reproduce the error
Step 1: Create a new Armature (Single Bone)
Step 2: Subdivide the bone
Step 3: Switch to Pose Mode
Step 4: Enable 'Auto IK' (Tool Shelf)
Step 5: Enable 'Automatic Keyframe insertion for Objects and Bones' (Timeline Editor)
Step 6: Select the last bone in the bone chain
Step 7: Press Play (Alt+A) and move (G key) the selected bone in the viewport
Step 8: Left click to confirm before playhead reaches end of Timeline.
Key frames will be created in the Timeline Editor but the movement of the bones will not be recorded.

Blend file includes Steps 1-6:


Blend file includes recording attempt:

Details

Type
Bug
Philipp Oeser (lichtwerk) closed this task as Archived.EditedSat, May 5, 8:43 AM
Philipp Oeser (lichtwerk) claimed this task.

Thanx for the report, I think this is not intended to work unfortunately.
Rotation is properly recorded, Location is recorded as well, but you are getting them all in the same place, because 'in the real world' (aka without AutoIK) you wouldnt be able to move the bone because it has a parent.
So location keyframes would not be valid in the FK chain anyways.
I guess what one would really want is visual rotation keyframes for every bone in the (temporary) IK chain. These are not selected though so they dont get keyframes...

I've also tried to follow the code here a bit and [despite some flag relating to INSERTKEY_MATRIX not being set as I would expect it -- but thats another story] it seems it's just not designed to support this.
This could probably be hacked in, but I dont think this is a bug, more like a limitation, @Joshua Leung (aligorith), please correct me if I'm wrong [you could also suggest this being a nice TODO: and I'll have a look at supporting visual rotation keyframees for all bones down the chain in this very special case...]

I think in this case, you are better off just setting up a 'real' IK and use that?

Anyways, I dare archiving this as a limitation (not a bug)