Theme save error
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
This has to be opened with word or open office writer...

Blender Version
Broken: (2.79)


Worked: (2.77a)

Short description of error

Exact steps for others to reproduce the error
Make Changes to Font size and color, try to save theme and error occurs.

Based on a (as simple as possible) attached .blend file with minimum amount of steps

Steps I have taken...
Use another version of blender works fine.
Restore factory settings, restart computer, restart Blender error reoccurred.
Uninstall and remove all residual blender files preform a Clean install - error reoccurred multiple times,
Search for the error message via google, nothing relevant applied.

This error also happens when I install addons from zip files, error reoccurred when I try to activate the addon.

Thank you for your support

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.May 7 2018, 1:16 PM
  • Do you have another python installation? Ensure you have no python executable available in your %path% envvar and test again.
  • Have you installed a 32bit version (or the 64bit version) of blender? of python?
  • When running python, what does the following snippet output?
>>> import pyexpat
>>> pyexpat.__file__

Marking as incomplete until we have this info

I ran command prompt and typed python this is what it said..

I have installed 64bit blender

Any help with this Please

Philipp Oeser (lichtwerk) raised the priority of this task from Incomplete to Needs Triage.May 16 2018, 5:07 PM

@LazyDodo (LazyDodo): you're on windows right? mind checking there?

I am sorry but you are all speaking another language to me, I have no clue what to do, yes I am on windows 7

try closing blender and renaming

C:\Users\YourUserName\AppData\Roaming\Blender Foundation\Blender\2.79

to

C:\Users\YourUserName\AppData\Roaming\Blender Foundation\Blender\2.79.bak

Again I do not understand what you are explaining, do you want me to rename the blender.exe to blender.bak or the entire 2.79 folder within appdata roaming

the entire 2.79 folder in appdata

Frank (Ottovan) added a comment.EditedMay 19 2018, 2:49 PM

Changing the folder name to 2.79.bak had no affect one the error in question.

Also I found Python in my blender install heres what it does when I open....

Advice please

Any help with this please - Thanks

Frank (Ottovan) updated the task description. (Show Details)

do you have any chance have the pythonpath environment variable set?

try running blender from the command prompt

cd c:\whereever\blender\is\installed
set PYTHONPATH=
blender.exe

Blender Ran from command prompt, but I do not understand what you mean by "set PYTHONPATH=" -advice please

Listen, I do appreciate the help but these encrypted solutions only leave me with more questions, I have yet to understand one of the solutions anyone has provided, I am no Newb to computers or blender , just looking for clear explanation please.

I gave you exactly the commands you needed to type, in the order you needed to type them in, i'm not sure what else to tell you.

I found help on blender discord, it seems the install version of blender does not work for me, using the zip version works, this can be closed.

Thank you

Philipp Oeser (lichtwerk) closed this task as Resolved.May 28 2018, 3:26 PM
Philipp Oeser (lichtwerk) claimed this task.

Glad it's solved, will close then.
@LazyDodo (LazyDodo) : is there a lesson to be learned from the fact the zipped version runs fine?

Frank (Ottovan) reopened this task as Open.EditedJun 16 2018, 6:56 PM

Well I am back and now my zip version is giving the errors as follows one is of save theme and the other is of activating an installed addon.


To go over some more of the basic things I have done...

I am having an issue(s) with saving a theme and activating certain addons (not all), Blender Dev Bug support suggested I use the zip, I did so and my issue was solved I was now able to activate said addons and save themes, but yesterday after noon, I was tweaking my theme a little went to save it and got an error again, so I thought I'd try my addons to see if that was still working and my fear where noticed by the returning error from the past.

I have un-installed 5-6 times cleaned registry deleted appdata roaming folders tried redownloading a new 64 bit version of 2.79 , no help, so I thought maybe my zip version got coruppted some how and re downloaded it, no help errors are still happening.

Blender is useless to me in this state -Pleas Help!

Also make note at the bottom of the error Pic's its says not a valid win 32 application, why is that error saying that when I have the 64bit version installed.

AT this point I am asking for help in completely removing Blender and starting clean, I have removed eveything I can find associated with Blender including %appdata% roaming Blender foundation (previous versions) deleted all registry keys That have an obvious Blender name, there are several registry entries that come up with a search for Blender but only have numbers (are these safe to delete). Please advise as Blender is how I make a living - Thank you again.

Frank (Ottovan) closed this task as Invalid.Jun 19 2018, 2:36 PM

@Frank (Ottovan) : sorry I couldnt help further, but may I ask why this is resolved/invalid for you now?
[if there is something you've done to make it work, please let us know -- as others might benefit from your findings as well...]

@Frank (Ottovan) : sorry I couldnt help further, but may I ask why this is resolved/invalid for you now?
[if there is something you've done to make it work, please let us know -- as others might benefit from your findings as well...]

Well I marked as invalid because it really isn't solved , I took the advise from the same person in discord who help me before, he told me to try and create another system user within windows and install and try it there and it works on the new user account, I kind of wish I knew what I corrupted on my main user to have Blender so un-usable.