Page MenuHome

VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering.
Closed, ArchivedPublic

Description

System Information
MacBook Air, MacOS 10.12.6, 1.7 GHz Intel Core i7, 8GB RAM.
(Activity Monitory show Blender using about 200 MB of memory.)

Blender Version
Broken: Blender 2.79b (installed May 4, 2018)

Short description of error
VSE crashes or (occasionally) hangs on sound strip during rendering.
I can open the same .blend file several times in a row, click only “Animate,” (no other UI actions), and VSE crashes (usually) on different instances of the same sound strip, or hangs (occasionally), or successfully renders a movie file. (See "SIX CONSECUTIVE TRIAL RUNS{F3282171}

" below.)

Some things I noticed:

  1. This usually happens 4-10 frames into a second sound strip when a first sound strip is already many frames into rendering. (For example: sound strip 1 starts on frame 100, sound strip 2 starts on frame 200, crash or freeze occurs on frame 205.)
  2. The files that crash are usually short and the same few (I’ll attach one). These were third-party sound effects, but crashes still occur when I read the file into the Audacity application, then re-export, and use the resulting sound file.
  3. Usually instances of the strip has already occurred several times in the .blend file, rendering successfully, but then a crash occurs on, for example, the fifth occurrence of that sound file.

Exact steps for others to reproduce the error
Open the attached .blend file and click "Animate". (Let me know if you additionally want the image files -- they ar large.)

SIX CONSECUTIVE TRIAL RUNS
RUN 1:
Crash after this console output:
“Append frame 285
Time: 00:00.14 (Saving: 00:00.11)
Writing: /tmp/Crash-on-sound-strip.crash.txt
Segmentation fault: 11”

And the crash.txt file contained:
“# Blender 2.79 (sub 0), Commit date: 2017-09-11 10:43, Hash 5bd8ac9

backtrace

0 blender 0x0000000100c32b1a BLI_system_backtrace + 58
1 blender 0x000000010013ee1a sig_handle_crash + 362
2 libsystem_platform.dylib 0x00007fffad789b3a _sigtramp + 26
3 ??? 0x7fc000007fc00000 0x0 + 9205357640488583168”

RUN 2: Crash, but after “Append frame 49”
RUN 3: Completed successfully
RUN 4: Crash, but after “Append frame 113”
RUN 5: Completed successfully
RUN 6: Crash, but after “Append frame 212”

NOTE: the crash is always 4 or 5 frames into the short sound strip.

When a render occasionally HANGS instead of crashes, it’s at the same place in the short sound strip. MacOS’s Activity Monitor shows about 73% CPU. Clicking “Stop this job” (“x”) next to the “Time Remaining” progress bar in VSE UI displays the text “Canceling…” forever with CPU remaining at 73%. I have to choose “Force process to quit” in Activity Monitor.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.May 7 2018, 12:57 PM

Cant reproduce, renders fine here.

  • Seeing you attached the bouncy-copy.mp3... Could you pack in the other media used (images, pngs, other mp3) as well? (Just so we are on the same track...)

marking as incomplete for the time being...

Here's a simplified .blend that still crashes. It has a single image (used as a 360-frame image strip) and 2 sound files.
I don't know how to bundle the image into the .blend file, but the 2 sound files seem to be there.
I'll add the image file here, and you can re-add the image strip.

New info: when I render without the image file, only sound files, then it tends to hang rather than crash.

Attached:

  1. image file to add as a image strip in VSE.
  2. short sound file.
  3. Long sound file
  4. v2 of .blend file that crashes




Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jun 20 2018, 3:22 PM

Tried to reproduce, however in output settings value of Video Codec item is empty.
What codec do you have set?

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Feb 4 2019, 5:41 PM

See attached screenshot for the codec settings.

Only now I realized, that this is 2.79 bug report
Can not reproduce this in 2.79 f4dc9f9d68b or in 2.8

Your blender build is older, please download latest version - ideally 2.8 as I will not be able to work on 2.79 anytime soon.

Richard Antalik (ISS) closed this task as Archived.Feb 19 2019, 1:01 AM
Richard Antalik (ISS) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

Okay, maybe the bug has been fixed as a side effect of something else then?
I will test on 2.80 as soon as it's officially released. I hesitate to remove my current installation in case something breaks, and I'll need to deal with reinstalling an old version...

On windows you can just download and run Blender, no need to install.
Not sure about other platforms.

Feel free to reopen If you still encounter bug.