Page MenuHome

Incorrect wave texture visualization
Closed, ArchivedPublic

Description

System Information
OS: Windows 7 64bits
32GB RAM DDR3 1800
1 x AMD RADEON R9 390 8GB (with last drivers)
1 x AMD RADEON R9 390X 8GB (with last drivers)
HDD 1TB

Blender Version
Broken: Blender 2.79.4 Hash: 9eb5aa3
Worked: Actually it is a bug that comes from version 2.78 but its arrangement has not been determinant. I have always believed that it was a configuration of my PC.

Short description of error
Both in the preview and in the render, when modifying the scale of the texture, it is lost or stops showing. This works correctly if I render with CPU. It also works correctly on NVIDIA video cards (at least 850m). I have disabled all optimization settings made by the AMD driver from the configuration and disabled Crossfire but I do not solve the problem.

Exact steps for others to reproduce the error
Simply render or preview and modify the Scale of the wave texture

Details

Type
Bug

Event Timeline

Someone here with AMDs can reproduce?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I'm guessing that this is still an issue with the latest blender build? https://builder.blender.org/download/

@Martín Sanchez (Martincho84) just to be clear, this is an issue with the OpenCL render, right?

Jacques Lucke (JacquesLucke) closed this task as Archived.
Jacques Lucke (JacquesLucke) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

Martín Sanchez (Martincho84) reopened this task as Open.EditedMar 19 2019, 4:35 PM

Apologies, I have been finishing my university studies and I have not been able to answer before.

I have the error with both Blender 2.79b and the last build of 2.79 (only OpenCL with AMD).


In version 2.8 Beta the same thing happens (only in OpenCL with AMD).


Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 19 2019, 4:44 PM

Seems to render correctly on my setup, I use Vega and Polaris architectures. I don't have access to an Hawai architecture card, but will test try to test with Fiji. I tested with latest blender2.7.

@Martín Sanchez (Martincho84) Can you provide a clinfo and systeminfo,txt?

Jeroen Bakker (jbakker) triaged this task as Needs Information from User priority.Mar 21 2019, 3:10 PM

I will download the last build of 2.79 and do tests

Bastien Montagne (mont29) closed this task as Archived.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

I confirm the incorrect visualization of wave textures using an AMD RX 580 (Polaris) for rendering.
The bigger the scale of a wave texture is, the less the texture is appearing.

That occurs on windows 7 SP1 and also on Ubuntu 16.04.5.

I tested Blender 2.78a, 2.79b, latest 2.79 and latest 2.80 (64bit versions). The result is always the same and incorrect.

Driver for Windows: 18.12.1.1
Driver for Linux: 18.40

CPU rendering delivers the expected correct result.