Page MenuHome

Undo mask brush in sculpt mode with dyntopo on, crashes Blender
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

win 7 gtx 550ti

Blender Version
Broken: Hash d5c1c0b
Worked: (optional) One of my old back up build hash 3c45fdd

Short description of error

Blender crashes in sculpt mode with dyntopo on.

Exact steps for others to reproduce the error

  • Go to sculpt mode
  • Turn Dyntopo on
  • Sculpt some strokes
  • Now lasso mask some part of the sculpted area
  • Undo the Mask, notice that first undo didn't work
  • Do another undo to make the undo happen
  • Now lasso mask again more or less the same area
  • And then undo again, notice some artifacts on the mesh
  • Do another lasso mask, Blender crashes

Details

Type
Bug

Event Timeline

Hi @Erick Tukuniata (erickblender) ,
I can not reproduce this crash nor any artifacts with my setup (Fedora 28/ GeForce GT 740), even when I previously make the mesh non-manifold.
It works fine here for 2.79a, 2.79b and latest master build of the 2.79series.
So maybe it is something specific to your setup. You probably tested this already with blender's factory-settings loaded, right? Do you have the latest nvidia drivers installed?

  • What build hash are you using?
  • Yep may be it a windows specific problem do you have a windows machine to try it?
  • Yes i tried with factory settings and i got the same behavior.
  • It isn't Nvidia drivers related because i have the latest and i tried with different machine.

build-hashes used that all worked fine within my Linux setup:

  • for 2.79a: 8928d99270f
  • for 2.79b: f4dc9f9d68b
  • for 2.79master: 0385b33f0b3 (from May 5th 2018) -- Edit 13th May 2018: seems as if I didn't test with this version after all. I must have used the wrong opened blender... sorry!

I don't have a windows machine available right now, but next week I will have access to one. If no one else has confirmed your bug till then I will give it another try on windows.

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

I can repro here (on linux)

Seems to be related to the UNDO refactor.

1  BM_log_entry_drop               bmesh_log.c       743  0x21d2682 
2  sculpt_undo_free_list           sculpt_undo.c     619  0x1e43005 
3  sculpt_undosys_step_free        sculpt_undo.c     1052 0x1e45796 
4  undosys_step_free_and_unlink    undo_system.c     182  0x276d296 
5  BKE_undosys_step_push_with_type undo_system.c     398  0x276e02a 
6  BKE_undosys_step_push           undo_system.c     448  0x276e343 
7  sculpt_undo_push_end            sculpt_undo.c     998  0x1e455fe 
8  paint_mask_gesture_lasso_exec   paint_mask.c      512  0x1e053c8 
9  gesture_lasso_apply             wm_gesture_ops.c  612  0x1850619 
10 WM_gesture_lasso_modal          wm_gesture_ops.c  658  0x1850846

There are a couple of open/confirmed issues with the UNDO refactor, I'll go over them again and see if these tasks can be merged.

@Erick Tukuniata (erickblender) : I'm sorry - I used the offical blender 2.79b to test this - I will keep in mind to always check with the latest master in the future. So yes with the current master build I can reproduce the bug as described. Sorry again! But with @Philipp Oeser (lichtwerk) the bug report is in good hands ;)

Philipp Oeser (lichtwerk) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Jun 8 2018, 10:00 AM

There have just been two fixes regarding sculpt/dyntopo (rB5330f1c5d136, rB624294063910)
With these changes I cant reproduce this anymore (thanx @Campbell Barton (campbellbarton)! )

So @Erick Tukuniata (erickblender) : could you check master build from https://builder.blender.org/download? (pretty sure this should be resolved there) and please report back if this indeed fixes it for you...

Marking as incomplete for the time being...

Yes just I checked and it is working now, meaning that is not crashing anymore but still you have to undo twice before the undo takes place. May be should close this one and open another one with the title " After lasso mask, Blender needs two undo before the undo takes place." ?

Philipp Oeser (lichtwerk) closed this task as Resolved.Jun 8 2018, 12:38 PM

@Erick Tukuniata (erickblender) : yes, that would be good (open other report for doubleundo).
Closing this one then (and thx for reporting back!)