Page MenuHome

Blender seems to crash in combination with the new undo system and dynatopo in sculpt mode
Closed, ResolvedPublic

Description

System Information
Windows 10 / Nvidia GTX 970

Blender Version
Broken: 2.79-c84b8d4
Worked: 2.79b

If I'm in sculpt mode and use dynatopo and use Scrape/Peaks for example and undo it and sculpt again blender crashed everytime. I tested it also on a other PC(from a friend...Windows 7) on a blender build without any modfikations and it happen everytime.

  1. Start Blender
  2. Switch to sculpt mode and activate dynatopo
  3. Switch in the setting in dynatopo from relative detail du brush detail
  4. Switch to the Scrape/Peaks brush and flat the edge from the cube with it
  5. Undo the steps and try again to flatten something

It should crash than.

Here also a Video do demonstrate it twice:
https://youtu.be/l7tQMuqjCXY

Cheers!

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Can confirm the crash.

Seems to be related to the UNDO refactor.

1  BLI_mempool_len                 BLI_mempool.c     479  0x29e56c5 
2  BLI_ghash_free                  BLI_ghash.c       1014 0x29d91f2 
3  bm_log_entry_free               bmesh_log.c       411  0x21ce69f 
4  BM_log_entry_drop               bmesh_log.c       699  0x21d25cf 
5  sculpt_undo_free_list           sculpt_undo.c     619  0x1e43005 
6  sculpt_undosys_step_free        sculpt_undo.c     1052 0x1e45796 
7  undosys_step_free_and_unlink    undo_system.c     182  0x276d296 
8  BKE_undosys_step_push_with_type undo_system.c     398  0x276e02a 
9  BKE_undosys_step_push           undo_system.c     448  0x276e343 
10 sculpt_undo_push_end            sculpt_undo.c     998  0x1e455fe 
11 sculpt_stroke_done              sculpt.c          5040 0x1e3eae8 
12 stroke_done                     paint_stroke.c    754  0x1e0bc7f 
13 paint_stroke_modal              paint_stroke.c    1176 0x1e0cfa8

GHash->entrypool is NULL here.

There are a couple of open/confirmed issues with the UNDO refactor, I'll go over them again and see if these tasks can be merged.

I can confirm this is happening.

Philipp Oeser (lichtwerk) lowered the priority of this task from Confirmed, Medium to Needs Information from User.

There have just been two fixes regarding sculpt/dyntopo (rB5330f1c5d136, rB624294063910)
With these changes I cant reproduce this anymore (thanx @Campbell Barton (campbellbarton)! )

So @Edward Agwi (SHiv0r), @soulfire (vejn), @Czarek Kopias (czarek) : could you check master build from https://builder.blender.org/download? (pretty sure this should be resolved there) and please report back if this indeed fixes it for you...

Marking as incomplete for the time being...

Have just tested the latest master and the bug is gone.

Philipp Oeser (lichtwerk) closed this task as Resolved.Jun 8 2018, 12:03 PM

Glad to hear! Closing then.