Text on Curve makes crash if the scene is linked and used on Sequencer
Closed, ArchivedPublic

Description

System Information
Windows 10 Pro
renderer: 'GeForce GT 650M/PCIe/SSE2'
vendor: 'NVIDIA Corporation'
version: '4.5.0 NVIDIA 384.76'

Blender Version
Broken:
version: 2.79 (sub 4), branch: blender2.8, commit date: 2018-05-15 17:37, hash: 4461be1, type: Release
build date: Wed 05/16/2018, 04:27 AM

Short description of error
Text on Curve makes crash if the scene is linked and used the linked scene as a strip in Sequencer.

Exact steps for others to reproduce the error

  1. Create a text object
  2. Create a curve
  3. Set the curve for the Text on Curve option under Properties Font rollout
  4. Save the file for eg. TextOnCurve.blend

  1. Create a new scene.
  2. Link the scene of the TextOnCurve.blend file
  3. Place the scene as strip in VSE
  4. Save the file for eg. LinkedScene.blend
  5. Reload (or try to load) the LinkedScene.blend file: crash!

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.May 16 2018, 12:04 PM

Are we talking about 2.79? 2.8?

in 2.79 master I get a crash with the old depsgraph, works fine with --enable-new-depsgraph

old depsgraph (crash because cu->textoncurve->curve_cache is NULL)

1  BKE_vfont_to_curve_ex         font.c          1079 0x25e240f      
2  BKE_vfont_to_curve_nubase     font.c          1347 0x25e3502      
3  do_makeDispListCurveTypes     displist.c      1545 0x2599ca3      
4  BKE_displist_make_curveTypes  displist.c      1782 0x259a9bd      
5  BKE_object_handle_data_update object_update.c 206  0x269aa25      
6  BKE_object_handle_update_ex   object.c        2660 0x2690b8d      
7  scene_update_object_func      scene.c         1562 0x26ee042

new depsgrpah (no crash due to different code path)

1   BKE_vfont_to_curve_ex                 font.c            1079 0x25e23fa 
2   BKE_vfont_to_curve_nubase             font.c            1347 0x25e3502 
3   do_makeDispListCurveTypes             displist.c        1545 0x2599ca3 
4   BKE_displist_make_curveTypes          displist.c        1782 0x259a9bd 
5   ensure_curve_cache                    drawobject.c      2321 0x19a3013 
6   drawDispList                          drawobject.c      4745 0x19af552 
7   draw_object                           drawobject.c      7669 0x19b9f86 
8   view3d_draw_objects                   view3d_draw.c     2929 0x1972b56 
9   ED_view3d_draw_offscreen              view3d_draw.c     3239 0x197379b 
10  ED_view3d_draw_offscreen_imbuf        view3d_draw.c     3371 0x1973d7f 
11  ED_view3d_draw_offscreen_imbuf_simple view3d_draw.c     3528 0x197458b 
12  seq_render_scene_strip                sequencer.c       3327 0x27139d5 
13  do_render_strip_uncached              sequencer.c       3503 0x2714342 
14  seq_render_strip                      sequencer.c       3623 0x2714896 
15  seq_render_strip_stack                sequencer.c       3769 0x2714e0a 
16  BKE_sequencer_give_ibuf               sequencer.c       3892 0x27153fb 
17  sequencer_ibuf_get                    sequencer_draw.c  956  0x19392d5 
18  draw_image_seq                        sequencer_draw.c  1159 0x1939b80

In 2.8 it's a whole different story, there's a crash, too, but I think it's too early to investigate 2.8 for these kind of bugs...
As a reference, here's a backtrace for 2.8

1  expand_scene_collection    readfile.c        9536  0x2451186 
2  expand_scene               readfile.c        9629  0x24517a2 
3  BLO_expand_main            readfile.c        9797  0x2452023 
4  read_libraries             readfile.c        10569 0x2453f30 
5  blo_read_file_internal     readfile.c        8754  0x244f142 
6  BLO_read_from_file         readblenentry.c   331   0x2435538 
7  BKE_blendfile_read         blendfile.c       388   0x2556544 
8  WM_file_read               wm_files.c        581   0x18deafa

That being said, I'd suggest to close this report (if it is for 2.8).
If it is for 2.79 I would like to hear if enabling the new depsgraph fixes the problem for you?
(I think fixing the old depsgraph will probably not happen anymore in the 2.79 series...)

Marking as incomplete until we have an answer...

Yes, works fine with new depsgraph!

Is the new depsgraph for 2.79 stable solution in general?

Philipp Oeser (lichtwerk) closed this task as Archived.Jun 20 2018, 3:25 PM
Philipp Oeser (lichtwerk) claimed this task.

Sorry for answering late here, I would say the new dependency graph is the new standard and there and it is very unlikely the old dependency graph will see fixes.
Archiving this since there dont seem to be issues with the new dependency graph.