Investigate why Spring rigs are broken in 2.8 with COW
Closed, ResolvedPublic

Description

Task to keep track of all the issues that are currently causing issues with the Spring/Autumn blenrig rigs in 2.8 when using COW. Fixing these is important for getting the Spring team working in 2.8 next week.

Solved Issues

  • Hook modifier on lattices doesn't work [SOLVED - rBb6e3430417d] - This was causing problems on Spring's eyes, which are almost exclusively deformed using hook-deformed lattices.
  • Double transform when both Armature Modifier + Mesh Deform are enabled on GEO_body [SOLVED - rB6a4ba9133ce7 ] - This was caused by the mdef vgroup option (T55097)
    • eg. In 01_025: Autumn (dog) rig has parts of geometry running off into space (i.e. you get dog body with various bits - face/head + feet - trailing off miles away). Rig is proxified.
    • e.g. 01_020: Spring rig has similar problems as the dog in 01_025, except there are skin-colored spikes.
  • Custom bones were invisible in object mode (T55068)
  • "Wireframe" option for custom bone shapes is ignored - This breaks control widgets with custom shape (e.g. "box" around the branch, or pyramids on feet) [SOLVED - rB35a298db520]

Workarounds Possible

  • Dark parts of eyes not visible - This is necessary for animators to check eyelines/facial poses. (Compare: 2.8 -
    , master:
    )
      • Probably cornea mesh is showing, due to drivers on "hide" properties no longer being able to work?
      • The cornea material should be marked/be set as "transparent"
      • Workaround: Use Mask Modifier instead to hide the geometry. (May need optimisations when all faces get removed)
    • Workaround/Proper Fix: Put objects to be hidden like this into a collection, and drive the visibility of that collection

Pending/Unresolved Issues

  • Evaluation/Editing Speed
    • Profiling suggests that the main costs are still just modifier evaluation (> 60%), particularly armature modifier (b-bone evaluation) and particles (perlin noise). COW related data copying and/or DM<->Mesh conversions were not major sources of speed issues.

Other Issues

  • PyController Removal + Drivers/Custom Properties Creation Script thing? - @Juan Pablo Bouza (jpbouza) reports that it shouldn't be an issue. To be confirmed?

To be checked:

  • Are there any other issues with Proxy-based workflow (apart from T55076)
  • Are any other parts of the rigs broken, apart from the obvious glitches above?

Details

Type
Bug
Joshua Leung (aligorith) triaged this task as High priority.

Regarding PyController Removal + Drivers/Custom Properties Creation Script thing , even though the rig works without it, I realized that the animations in 2.79 are keying these api defined properties, so I should add the script with the drivers trick anyway so that animations work properly.

Profiling suggests that the main costs are still just modifier evaluation (> 60%)

Which revision was used for profiling?

@Sybren A. Stüvel (sybren) Didn't note the exact revision, but it one from was Monday (14 May) afternoon, (from around 4-5:30pm). I should probably run it again (maybe daily) to check if things have changed with the DM/modifier cleanups since.

Joshua Leung (aligorith) updated the task description. (Show Details)
Joshua Leung (aligorith) updated the task description. (Show Details)
Joshua Leung (aligorith) lowered the priority of this task from High to Normal.
Dalai Felinto (dfelinto) closed this task as Resolved.May 28 2018, 6:29 PM