Page MenuHome

Workbench: Transparency mode (See through)
Closed, ResolvedPublic

Description

Option to render the scene where every object is 'transparent'

Code inside workbench folder, but separate draw engine as it uses forward shading.

http://cg.cs.uni-bonn.de/en/publications/paper-details/muenstermann2018-mboit/
http://casual-effects.blogspot.nl/2014/03/weighted-blended-order-independent.html

  1. Memleak (startup + see through = GPUShader leak).
  2. Color management issue (the archiviz scene is impossible to see without manually adjusting exposure).

    Would suggest that the file is setup with incorrect lighting for workbench. As everything has a white color and no material color everything is overexposured. By configuring the material colors this is overcome. The other option is to turn off color management, but that seems to me not the issue here.
  1. Things are too dark (or rather, not blending with the background?) - Clement said you are aware of this, but leaving it here for completion sake.

    Will do a test with a Background multiply blend and a revealage buffer. And see if the results are better. if this is not the case, will continue the way clement proposed (changing the CM curve). At the end I implemented the revealage buffer.
  1. Center selection not the first thing selected - not a workbench issue per se, but we need this tackled, so if you could at least report to Campbell. There is a chance the issue is the order of drawing.
  2. Bones ... at the moment they are occluded. We should either not occlude them, or to force them to their own transparency. But right now a bone inside a box is not drawn.
  3. Naming - not sold on see through, we may want to unify the name with bones. Or use something SU like as X-Ray.

    Check with William/Pablo for final naming.
  1. Lamps/Cameras are hidden.

    Lamps and cameras are drawn by the object mode and uses a depth test. this hides the objects if they are underneeth. Can clear the depth test. But will also have other consequences. like grid rendering etc. Need to check what the users expect.
  1. Editmode cage gets occluded by other objects.

    Is similar behavior as before. need to check is we want to change this behavior.

Current state

When supporting meshes are drawn in the back these will be checkered

Left without checkerboard, Right with checkerboard

With revealage buffer

Without revealage buffer

Details

Type
To Do

Event Timeline

Jeroen Bakker (jbakker) triaged this task as High priority.
Jeroen Bakker (jbakker) raised the priority of this task from High to Needs Triage.
Jeroen Bakker (jbakker) renamed this task from Workbench: Transparency mode to Workbench: Transparency mode (See through).May 22 2018, 9:46 AM
Dalai Felinto (dfelinto) triaged this task as Normal priority.
Dalai Felinto (dfelinto) closed this task as Resolved.May 28 2018, 6:29 PM