Page MenuHome

Workbench: LookDev
Closed, ResolvedPublic

Description

Add a new pass in eevee

this pass will render a number of spheres

  • uses DRW_viewport_matrix_override_set to set the camera to a default location
  • uses a copy of the DefaultLitPass to render the 2 spheres + color palette
  • uses backculling so no depth check is needed.
  • render it during fx (or after)
  • use GPU_framebuffer_viewport_set to render the spheres in the corner
  • before rendering set num_lights to 0 so no shadows and lights are calculated during this call.

TODO:

  • when pressing N and transparency is turned on, the lookdev balls should slide with the sidebar
  • rendering the background should be an option
  • option to disable the lights completely
  • default diffuse ball should be less shiny

Details

Type
To Do

Event Timeline

Jeroen Bakker (jbakker) lowered the priority of this task from Needs Triage by Developer to Normal.May 17 2018, 2:47 PM
Jeroen Bakker (jbakker) created this task.
Jeroen Bakker (jbakker) triaged this task as Confirmed, High priority.
Jeroen Bakker (jbakker) updated the task description. (Show Details)
Jeroen Bakker (jbakker) moved this task from Tasks to Doing on the Code Quest board.

Amazing feature, thanks. I noticed only HDR is working for the time being. Will we be able to use EXR images as well?

Could be nice to be able to:

  • Have unlimited rotation (and a key to not have to go in the popover to rotate the light)
  • Have a blur setting
  • Have a strength setting since it's not the HDRI map from the environment tab. (maybe use the render HDRI if scene light is activated and the studio HDRI when it's disabled)
  • Have a better map to test because the current one is really bad ^^
Dalai Felinto (dfelinto) closed this task as Resolved.Jun 4 2018, 10:25 AM

Hi guys,

Why do we have so much difference between lookdev and eevee?


With a simple HDRI map, the result should be the same.