Page MenuHome

No "Open In Low Resolution" ability on MacOS [2.8]
Closed, InvalidPublic

Description

System Information
MacOS/Macbook Pro (Mid 2015)

Blender Version
Broken: 2.8
Worked: 2.79

So, with retina screens the pixels are 4x as dense, which means that most software (specifically those based off of a vector/non-image UI) need to render 4x as many pixels to show on your screen without looking clunky and pixelated. The problem with this is that it takes up more processing than needed. Most of us retina users would normally go to: [Wherever Blender is Located>Blender>Get Info>Open In Low Resolution] to open the app in a normal resolution, which lets us use blender without having crippling lag in the viewport. Well, for some reason checking the "Open in Low Resolution" box does nothing, and, although the UI is super sharp, it has immense lag and input delay from the excessive amount of pixels it has to render.

Exact steps for others to reproduce the error
Above^

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) closed this task as Invalid.
LazyDodo (LazyDodo) claimed this task.

Thank you for the report. Currently we are aware of many issues in 2.8 and actively working to fix them. But since replying to reports takes time, we have decided to limit bug reports to module team members.

@William Reynish (billreynish) try to run blender with the "Open in Low Resolution" option, it seems there is a bug, both 2.8 and latest 2.79 experimental build.

When running from the Application folder, the interface is blurred, when from other folders this option just doesn't work.

macOS 10.14.3

@Yevgeny Makarov (jenkm) Here it is blurry no matter what, if I use that option.

There is a patch to add pixel scaling to the Eevee viewport similar to Cycles. That is probably how the issue should be addressed.

In the 2.79b there is no blur (not sure if it is visible in this screenshot, you need to look at the actual size).

@Yevgeny Makarov (jenkm) I don't know why that would be. It could have to do with the OpenGL version or driver used. But I'm also not sure this is a configuration we should worry about supporting. It is mainly meant for debugging, not general use.

@William Reynish (billreynish) I'm not really worried about this feature, but it just works fine in the 2.79b but in latest 2.79.x no longer, so there is definitely a bug.

There may have also been a change in the newer macOS SDK that we use to build, with a different scaling algorithm. Not necessarily a bug.