Page MenuHome

Theme setting for properties, image, movie clip editor
Closed, ArchivedPublic

Description

Blender Version
Broken:

Blender 2.79
Hash: 5bd8ac9

Blender 2.76b
Hash: f337fea

Worked: Probably never

Short description of error
OK, this confused me when I tried making my first theme. For properties, "Title" changes the same thing as "Region Text Titles" for the other editors. If this isn't a bug, it sure is weird and confusing when making a theme.

Also, I just noticed today(5/26/2018). "Region Text Titles" for the movie clip editor, also changes the image editor setting. If you change the region text titles for the image editor, it doesn't do anything.

Exact steps for others to reproduce the error
Screenshots should be enough.

Details

Type
Bug

Event Timeline

Zachary (AFWS) renamed this task from Theme setting for properties editor to Theme setting for properties.
Zachary (AFWS) renamed this task from Theme setting for properties to Theme setting for properties, image, movie clip editor.

reg. [1]: For the Properties Editor The Panels Title is not changed by Region Text because it is not in a Region (Properties Editor doesnt have a N or T Region)
reg. [2]: cannot reproduce unfortunately, changing Region Text Titles for the MovieClipEditor only affects the MovieClipEditor here and changing Region Text Titles for the ImageEditor it has the expected result here...

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.May 28 2018, 1:51 PM

Could you show us how changing Region Text Titles for the MovieClipEditor actually changes it for the ImageEditor as well?

Marking as incomplete for the time being...

Yeah, the second one is not a issue. I think what I did was had a image editor open to the left of a movie clip editor. I had the tool panel and properties panel closed for the Image editor ,but both of them open for the movie editor. It made me think the properties panel was changing for both. The first issue makes a little more since now ,but it looks like it wouldn't be so confusing if there wasn't settings that wasn't used. How many editors have tab settings for the theme ,but yet don't have tabs? I've never seen tabs in the outliner, info, properties, etc ,but it's under theme settings.

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

reg. [1]: to be precise, the Properties Editor main view is indeed a region, but of RGN_TYPE_WINDOW, the "tabs" you are talking about are usually of type RGN_TYPE_UI or RGN_TYPE_TOOLS.
When it comes to theme colors (and especially the titles) this then gets switched depending on region type here, so when we are in a RGN_TYPE_WINDOW it will end up being the Titles theme setting, when we are RGN_TYPE_UI or RGN_TYPE_TOOLS it will end up being Region Text Titles... Wording might be a bit confusing, but it makes sense, no?

So why does a SpaceType have theme settings it is not even using? It is just part of generic code for all SpaceTypes. This could of course be made more granular (skipping theme entries that SpaceTypes are not using), but this is not a bug, more of a TODO. Once upon a time, there was even an exception for the Properties Editor and the Outliner, but that was removed in rBf24392805515. @William Reynish (billreynish): not sure what you would think of this [skipping theme settings a SpaceType is not using]?

Also note that there was a discussion about (simplified) theme settings before, see T45352, T54115

Anyways, archiving for now, since the initial report seems adressed, feel free to comment again if issues remain.