Page MenuHome

Corrupt mesh after sculpting with dyntopo
Closed, ArchivedPublic

Description

System Information
Windows 64bits

Blender Version
Blender 2018-04-12 08:30
Hash: 2da3949e26f
soc-2017-normal-tools

Short description of error
Sculpting a mesh with dyntopo mode when I get out of the sculpt mode and go back to object mode the mesh corrupt completely, creating holes, triangles, sharp edges,...

Before


After

Exact steps for others to reproduce the error
I don't have way to reproduce it other time, but I provided with files before and after the problem.

Details

Type
Bug

Event Timeline

Alberto Velázquez (dcvertice) renamed this task from Corrupt mesh after sculpting to Corrupt mesh after sculpting with dyntopo.May 26 2018, 11:44 AM
Alberto Velázquez (dcvertice) updated the task description. (Show Details)

I'm getting crashes with UNDO, but these are also in master (see T55051, T55033), but I cant reproduce the corrupt mesh when going to objectmode

  • are you sure this is only happening in soc-2017-normal-tools? or do you get it in master as well?

I continued working with soc-2017-normal-tools branch and I saw the problem two more times, so I can confirm the bug in the branch. By my work I only use this branch and the error happens one time each ¿4-5 hours? of work. So it's not easy to reproduce. I will try next time that I do a sculpt with dyntopo to use the master branch.

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.May 28 2018, 3:30 PM

@Alberto Velázquez (dcvertice): I'll keep this open but mark as incomplete until we know if master has the same issue.
For others: please keep this Open (even if it takes a while to reproduce/have an answer here...)

btw: @Bastien Montagne (mont29): do we accept reports for branches in general?

There have just been two fixes regarding sculpt/dyntopo (rB5330f1c5d136, rB624294063910)
With these changes I cant reproduce this anymore (thanx @Campbell Barton (campbellbarton)! )

So @Alberto Velázquez (dcvertice) : could you check master build from https://builder.blender.org/download? (pretty sure this should be resolved there) and please report back if this indeed fixes it for you...

Philipp Oeser (lichtwerk) closed this task as Archived.Jun 20 2018, 3:35 PM
Philipp Oeser (lichtwerk) claimed this task.

@Alberto Velázquez (dcvertice): I'll archive this now, feel free to reopen if issues remain