Error: EXCEPTION_INT_DIVIDE_BY_ZERO Blender will not start
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Windows 10

Intel i5-7300U 2,6Ghz
intel (R) HD Graphics 620 graphics card

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) 2.79 (sub 0)

Worked: (optional) never

Short description of error

Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 10:10 AM Windows
argv[0] = blender.exe
argv[1] = -d
read file
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera

Error: EXCEPTION_INT_DIVIDE_BY_ZERO

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

It seems to be a programming error that makes Blender crash on Startup and not open. Suppressing Startup errors with the respective flag doesn't help . I use Intel chip and it is updated and Windows 10 completely updated. Crash happens on both 32bit and 64bit versions.

There is https://developer.blender.org/T45673
but everything said there did not solve the error, it seems to be still an imminent programming error in Blender

disable crash handler gives this

Blender 2.79 (sub 0)
Build: Thu 03/22/2018 10:10 AM Windows
argv[0] = blender.exe
argv[1] = -d
argv[2] = --disable-crash-handler
read file
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera

C:\Program Files (x86)\Blender Foundation\Blender>

It's a blender programming error somewhere and I hope that it can be resolved. Happy to do any additional checks.

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Jun 7 2018, 10:47 AM

Just generic other things you could try:

  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.)

Marking as incomplete until we have these tried...

Bastien Montagne (mont29) closed this task as Archived.Jul 12 2018, 4:10 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.