Bad performance even hairs are hidden
Closed, ResolvedPublic

Description

System Information
W10 64b

Blender Version
2.79

Short description of error
Hairs are recalculated, even it is hidden. So it has poor performance during playback.

Exact steps for others to reproduce the error

  1. open
  2. Play animation (I get around 15FPS)
  3. Remove animation from EFFECTOR or delete effector - I am using it for grass move
  4. Performance is back

It is strange, bacause hairs are hidden, but something happen on the background, even they are not visible. Maybe it is limitation of Blender.

Details

Type
Bug

Without having checked in detail (yet) the dependency graph will only truly skip evaluation if things are on a hidden layer (so usually hiding objects is not enough)
(hiding particle systems might be a bit different, as I said, havent checked yet)
See also T53251 for the case of (armature) modifier still being calculated (though hidden).

so workaround for now: put object with particle systems on a hidden layer (and keep a instance of object without particle system in visible layer if neccessary)

Yes, you've got it. It must be moved to another layer. Only hidden is not enough. Thanks!

Philipp Oeser (lichtwerk) closed this task as Resolved.Thu, Jun 14, 9:26 AM
Philipp Oeser (lichtwerk) claimed this task.

Looks like this is resolved.