Typo in "blender --debug-cycles" Output When CUDA Unavailable
Closed, ResolvedPublic

Description

Blender Version
Broken: Blender 2.79

Short description of error
The word "was" is mistyped as "wad" in the sentence "Neither precompiled kernels nor CUDA compiler wad found, unable to use CUDA", visible when running blender --debug-cycles.

Exact steps for others to reproduce the error

  1. Uninstall CUDA
  2. Run blender --debug-cycles

Observed behavior:

I0611 23:08:13.094699 26748 blender_python.cpp:186] Debug flags initialized to:
CPU flags:
  AVX2   : True
  AVX    : True
  SSE4.1 : True
  SSE3   : True
  SSE2   : True
  QBVH   : True
  Split  : False
CUDA flags:
 Adaptive Compile: False
OpenCL flags:
  Device type    : ALL
  Kernel type    : DEFAULT
  Debug          : False
  Single program : True
  Memory limit   : 0
I0611 23:08:13.127159 26748 device_opencl.cpp:63] CLEW initialization failed: Error opening the library
I0611 23:08:13.128432 26748 device_cuda.cpp:2096] CUEW initialization succeeded
I0611 23:08:13.132863 26748 device_cuda.cpp:2107] Neither precompiled kernels nor CUDA compiler wad found, unable to use CUDA

Eexpected behavior:

I0611 23:08:13.094699 26748 blender_python.cpp:186] Debug flags initialized to:
CPU flags:
  AVX2   : True
  AVX    : True
  SSE4.1 : True
  SSE3   : True
  SSE2   : True
  QBVH   : True
  Split  : False
CUDA flags:
 Adaptive Compile: False
OpenCL flags:
  Device type    : ALL
  Kernel type    : DEFAULT
  Debug          : False
  Single program : True
  Memory limit   : 0
I0611 23:08:13.127159 26748 device_opencl.cpp:63] CLEW initialization failed: Error opening the library
I0611 23:08:13.128432 26748 device_cuda.cpp:2096] CUEW initialization succeeded
I0611 23:08:13.132863 26748 device_cuda.cpp:2107] Neither precompiled kernels nor CUDA compiler was found, unable to use CUDA

Details

Type
Bug