[Vertex Group] "Delete all unlocked groups" not working
Closed, ArchivedPublic

Description

System Information
Win10

Blender Version
Broken: 2.79b f4dc9f

Short description of error
I locked 2 groups, I clicked "Delete all unlocked groups" in the menu.
However, all groups are cleared, both locked and unlocked.

Update:
I found that its not working only after working a while on Blender, like assigning and removing vertices from groups, switch edit mode on/off etc.

If it's not working, the following steps can make it work again for a while, for unknown reasons...

  1. save
  2. new a startup file
  3. open the .blend file you saved in step 1

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Jun 13 2018, 11:50 AM

Seems I cannot reproduce this (I know you've mentioned it only happens after a while of working, but I did quite a bit of assigning/removing, obmode/editmode switching to no avail...)

The fact that this wont happen in a saved/reopened file apparently makes it even harder to reproduce.
Could you find the steps that actually lead to this behavior?
(Giving us the log of the Info-Editor [where operators and property changes are recorded] might also help...)

Marking as incomplete for the time being...

OK, trying.

Just found out that saved/reopened only fix it for a while, the "Delete all unlocked groups" will eventually be broken again at some point.
The real trigger is still unknown though.

Bastien Montagne (mont29) closed this task as Archived.Jul 12 2018, 4:15 PM
Bastien Montagne (mont29) claimed this task.

I’m sorry, but we cannot investigate an issue we cannot reproduce, so will archive this report until someone can give enough elements to consistently reproduce it. Thanks for the report anyway.

Sorry for that, I can't find the rule of it.

One thing I suspect is: The mesh having the problem is an imported fbx made by 3dsmax, with vertex groups.