Page MenuHome

Regression: selection of vertex objects and partly lamps doesn't work anymore since a couple of days
Closed, ResolvedPublic

Description

System Information
Windows 8.1, I3 4030U with Intel® HD-Grafik 4400 and latest driver

Blender Version
Broken: d0a1677
Worked: some days ago, but don't have the buildbot numbers any more

Short description of error
with all settings at default, objects consisting only of verts can't be selected any more, the sun too if only it's "ray" are visible. Switching from automatic in user pref to occlusion queries or depth picking still work.

Exact steps for others to reproduce the error
Open default scene, edit the cube to only keep the verts, go back to object mode and try to select.
I made a file to make it faster:


Neither the cube nor the lamp are possible to select. Note that in this file, the zoom level is important, so don't move the camera.

Details

Type
Bug

Event Timeline

Cannot reproduce with a NVidia 970m (driver 390.59) on linux, automatic still working fine here...

@Philipp Oeser (lichtwerk) thanks for testing, all intel cpus have integrated GPUs, maybe there is a way to force Blender to use the iGPU instead of the discrete one? Auto I guess select the code path depending on the GPU, so you certainly don't use the same code, even if the option is the same?

jan bauer (janb) renamed this task from Regression: selection of point clouds and partly lamps doesn't work anymore since a couple of days to Regression: selection of vertex objects and partly lamps doesn't work anymore since a couple of days.Jun 14 2018, 4:02 PM

On Windows and with intel GPU, Automatic seem to take the "OpenGL Select" code path as selecting it manually leads to the same problem. Note that in this file, the zoom level is important, so don't move the camera.

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.Jul 20 2018, 4:20 PM

I can confirm same issue on Linux here (with also an Intel 'GPU'), Occlusion Queries works, but not OpenGL Select. Automatic seems to select the first one for me though…

@Campbell Barton (campbellbarton) iirc, you know selection code quiet well?

Strange, d0a1677 works for me, but not current head (c085d9b1bee0ece984ae45cab85d75fe17a299c3).

Edit, d0a1677 is from master, this hasn't worked in 2.8x for a long time.

Brecht Van Lommel (brecht) closed this task as Resolved.Mon, Apr 1, 2:31 PM

This should be long fixed.