Page MenuHome

Master GPU Cuda render tile at full screen res crash's blender or gives Cuda sync error
Closed, ArchivedPublic

Description

System Information
Win 10, Nvidia 750ti 2gb, Latest drivers, i5 12GB ram

Blender Version
Master
Works in 2,79b

Set render tile size for GPU rendering with cuda to full screen res e.g 1920x1080, builds BVH etc OK ,starts to render but either Blender crash's or sometimes your get a cuda sync error message

Exact steps for others to reproduce the error
Same as above

Details

Type
Bug

Event Timeline

Any chance you can check your event log for any TDR related events around the time of the crash?

It wasn't a time out issue, Blender would just stop operating and windows message would pop up saying blender had crashed and needed to close. Ill try to get some debug info later, some times it list a cuda line number with the error if doesn't just hard crash blender.

I tried the Benchmark scene with the sheep, and got the following rather than a hard crash this time:

I0616 16:16:50.098348 8188 device_cuda.cpp:850] Buffer allocate: work_tiles, 40 bytes. (40) in device memory
CUDA error: Unknown error in cuCtxSynchronize(), line 1712

Refer to the Cycles GPU rendering documentation for possible solutions:
https://docs.blender.org/manual/en/dev/render/cycles/gpu_rendering.html

CUDA error: Unknown error in cuMemcpyDtoH((uchar*)mem.host_pointer + offset, (CUdeviceptr)(mem.device_pointer + offset), size), line 961

If I drop the render res to 720z420 as single tile render it renders but at 100% when should denoise it gives another error:

CUDA error: Launch failed in cuMemcpyDtoH((uchar*)mem.host_pointer + offset, (CUdeviceptr)(mem.device_pointer + offset), size), line 961
Error: CUDA error: Launch failed in cuCtxSynchronize(), line 1390

Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.EditedJul 13 2018, 1:47 PM

If the render crashes in a simple file with 1920x1080 tiles, please attach the .blend.

For the victor/sheep benchmark, it may still be running out of memory even if the error is unclear. There will be 12GB - 4GB = 8GB host memory available, which is potentially not enough to render this file. Especially with such large tile size, which should not be needed anymore, just use a small tile size like 64x64.

The most important thing for us to debug this is to attach the full log from running Blender with --debug-cycles and the resulting crash. If you make any changes to the file we also need to know, since for example the standard victor.blend does not have denoising enabled.

Bastien Montagne (mont29) closed this task as Archived.Jul 25 2018, 9:36 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.