Bool is not visible in the render if one of the objects in the second window is in local view
Closed, ResolvedPublic

Description

Situation on the following video:

https://www.youtube.com/watch?v=2RtIqt2VDhk&feature=youtu.be

CPU: Intel core I7 960
RAM: 12 GB
GFX: nVidia Geforce GTX 770 4GB
OS: Windows 7 64 Bit
Drivers: Forceware 398.11
Blender: 2.79 SVN, 2017-09-11 10:43{F3741286}

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Jun 20 2018, 11:35 AM

Cannot reproduce here.
Tried to set this up as described in the video, like so:

and have no issues rendering (boolean modifier is intact)

To progress with this report:

  • could you check above .blend file and tell us if you have issues with this as well?
  • could you provide your example .blend file, so we can have a look?

Marking as incomplete for now...

Hi. it seems that this situation occurs only when we render scene in the same window, but when we render to a new window everything looks good:

New video below:

https://youtu.be/8DkGnPSXS_0

Hm, weird, still cant reproduce (2.79, 2.79b and master on linux, 970m, 390.59 drivers) -- rendering to UV Image Editor also fine here...

Just to make sure:

  • could you try a recent build from https://builder.blender.org?
  • could you check if there is an addon involved? (check this with File > Load Factory Settings)
  • have you changed anything to the file I've posted? (seeing the lamp is now an area lamp in the video [which itself isnt a problem, just asking...])
Nanomanpro added a comment.EditedJun 20 2018, 3:28 PM

I have just downloaded the latest build and problem is still there:

https://youtu.be/o068ZAWSzzg

Blend file:

Ah, view order seems to have an effect (if left 3D view is in local > no problem, if right view is in local > problem)
Will have a closer look...

Philipp Oeser (lichtwerk) raised the priority of this task from Incomplete to Confirmed.Jun 20 2018, 3:52 PM

Thank you Philipp :)

Philipp Oeser (lichtwerk) lowered the priority of this task from Confirmed to Low.Jun 21 2018, 2:29 PM

Doesnt seem to be an issue with the new dependency graph.
[run blender with --enable-new-depsgraph option]

log from old dependency graph on render:
(without digging deeper it looks strange that we have no tag_update for the "base" object? also not sure where MECube.002 comes from? it's not in data.meshes at all...)

DAG_id_tag_update_ex: id=OBbool flag=2
DAG_id_tag_update_ex: id=OBbool flag=2
DAG_id_tag_update_ex: id=MECube.002 flag=7

log from new dependency graph on render
(looks like properly doing something on "base" - sounds good...)

DEG_id_tag_update_ex: id=OBbool flag=2
DEG_id_tag_update_ex: id=OBbool flag=2
deg_evaluate_on_refresh: layers:16777217, graph->layers:16777217
BKE_mesh_eval_geometry on MECube.001 (0x7f1b41182408)
BKE_object_eval_local_transform on OBbool (0x7f1b41180608)
BKE_object_eval_uber_data on OBbool (0x7f1b41180608)
recalcdata bool
BKE_object_eval_done on OBbool (0x7f1b41180608)
BKE_object_eval_uber_data on OBbase (0x7f1b41180008)
recalcdata base
Depsgraph updated in 0.002313 seconds.
DEG_id_tag_update_ex: id=MECube.002 flag=7

Soo, as this seems to be a non-issue with the new dependency graph: I would like to ask @Sergey Sharybin (sergey) if we can close these reports right away?
[will put it on low priority for the time being... and actually assign @Sergey Sharybin (sergey), because I would not know how to proceed anyways except debug the old dependency graph further which seems like a waste of time?]

Sergey Sharybin (sergey) closed this task as Resolved.Mon, Oct 29, 12:57 PM

If the bug does not happen with new dependency graph, we can consider it solved. Also, keep in mind that local view and such is a subject of reconsidreation in 2.8.

Thanks for the report, but unless it's a bug in 2.8 would consider it solved :)