Blender crashes on startup on windows 10 ! When run from console I get this error :EXEPTION_ACCES_VIOLATION.
Closed, ArchivedPublic

Description

Hello everyone , Blender crashes everytime I try to run it . Every single time . When I run Blender from console I get this error :


My pc :
-GPU: GTX 1050
-CPU: i5 7300HQ 64 bit
-8 GB RAM and 1TB of space ( a gaming pc , and also with the latest graphic card driver)
-Windows 10
I think I know what's the cause of this issue :the windows updates. When I last ran this program was about 5 months ago ,before I completely reset my computer, it was working fine .After I reset my computer I forgot about blender and never ran it since then . Now I cancelled every single windows update except of the graphic cards driver updates,because they were killing my time and my computer's space .Before the reset , I had quite a few of Microsoft updates and maybe that's why Blender worked correctly back then . So please consider this error .I tried installing ALL of microsoft updates ,but for some reason all of them failed .

I also tried installing an older version , so I randomly clicked on 2.69 , which to my amazement worked fine .But the only thing that bothers me is the image which I don't like because it is too bright :

If you can tell me how to make the image darker , (like the current version of blender), I will work on this version without any problems .Please help me fix Blender ,I really want to do some work in it .Thanks in advance !!!

Details

Type
Bug
Alex (Sweet_FX) triaged this task as High priority.
Alex (Sweet_FX) created this object with edit policy "All Users".
Alex (Sweet_FX) changed Type from OpenGL Error to Bug.
Philipp Oeser (lichtwerk) lowered the priority of this task from High to Incomplete.Jun 21 2018, 3:49 PM

regarding the second issue: it is a Theme User Preference (you can switch these in File > User Preferences > Themes -- there are a couple of presets there)

regarding the first issue: there are a couple of things you could try:

  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker) This is indeed important!.
  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.
  • Try to re-download and re-install Blender.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Try to run Blender through Software OpenGL, this will be much slower however, if everything works then it means that the bug is spefic for your GPU/Driver and you should report the bug to your GPU vendor instead.

On MS-Windows: Download this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally.

Marking as incomplete until we have these tried...

Hello,

I had the same error on Windows 10.

Re-downloading and re-installing the latest version of blender just now from the website first gave me an error akin to "openAL32.dll not found". I then had to make a repair install and now the error seems to be gone for me.

If you still want to track down the error:

My PC:
GPU: Intel(R) HD Graphics 4000
CPU: Intel(R) Core(TM) i7-3840QM CPU @ 2.80GHz
32 GB RAM
Windows 10 64 bit

I usually use one of the "testbuild" versions, which doesn't have the error:

I downloaded the erronous version on 29.10.2017 but thought it would be a problem on my end and thus simply continued to use the testbuild-version.

hth

could you try a 2.79 build from the buildbot at https://builder.blender.org/download/ and see if that's any better for you?

regarding the second issue: it is a Theme User Preference (you can switch these in File > User Preferences > Themes -- there are a couple of presets there)

You didn't understand ! I want it to be like all other users have it . I didn't modify it , this is how it first looked when I opened it . I can't find any presets , it is too complicated for a noob like me .

regarding the first issue: there are a couple of things you could try:

> 1. Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker) This is indeed important!.

2.Try to disable any running antivirus.
3..Ensure you have no python executable available in your %path% envvar.
4.Try to re-download and re-install Blender.
5.Try the latest build from our buildbot.
6. Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
 Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
 Try to run Blender through Software OpenGL, this will be much slower however, if everything works then it means that the bug is spefic for your GPU/Driver and you should report the bug to your GPU vendor instead.

On MS-Windows: Download this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally.

Marking as incomplete until we have these tried...

1.I already said I have gpu graphic card driver up to date ,
2.I don''t have any antivirus on my computer , even windows defender is deactivated.
3.I don't know what that means , please be more explicit , it is too complicated for a noob like me
4.Already tried that a lot of times ., the same result
5.I tried that (basically what LazyDodo said ) and the blender runs but after 20-30 seconds it crashes without a warning or anything like that.
6.Again you should tell me what to write in console because I am a noob
7.I don't know where that would be ,but pretty sure it doesn't have anything to do with the crash.
8.Again how do I do that?

Wow , I downloaded that file and put it into the 2.69 Blender version and now the image is not bright anymore , but it is very,very laggy.

if the problem goes away when you drop in the opengl32.dll the issue is your gpu drivers and there's not much we can do about that from our end.

How is that my GPU driver , if my PC tells me that it is up to date ? You didn't understand . On the 2.69 version it worked fine ,the image was fine ,but it was very very laggy . On the 2.79 version it kept crashing ,nothing changed , literally the same thing .

the dll makes it use a software implementation of opengl (hence it will be very laggy) instead of your gpu drivers, the issue with the brightness went away, hence the issue is your drivers.

just because your drivers are up to date it doesn't mean they don't have issues.

Yeah but on version 2.79 it is still crashing , making no difference ? What do you have to say about that ?

  1. I don't like your combative conversation style ,tone it down please.
  1. Might be another issue, hard to tell, if you run it with the build you got from the build bot (so not the official 2.79) there might be an additional line in the crash message with the faulting module name

1.I apologize for my language ,but for 3 days I am searching for the solution everywhere and I seem to be the only one to have it which is very frustrating .
2.It is the official 2.79 , the build bot crashes after 30 sec ( so it works but for a short time )

Ok, lets try this:

  1. Download the latest 2.79 build from the build bot at https://builder.blender.org/download/
  2. unzip it somewhere
  3. Drop in the opengl32.dll
  4. Run it from the console like you did in your first screenshot.
  5. take a screenshot of the console once it crashes

@Alex (Sweet_FX) : sorry about the Themes, wasnt aware this was an actual glitch... my bad
Lets first try what @LazyDodo (LazyDodo) suggested, other suggestions can wait for now


Here it is. The build works ,but is very laggy .

Thanx for testing, the lag is normal, as we said before:

Try to run Blender through Software OpenGL, this will be much slower however, if everything works then it means that the bug is spefic for your GPU/Driver and you should report the bug to your GPU vendor instead.

OK, so it looks like it is you GPU drivers then. You said your drivers are up to date, but I still did not understand if these are drivers downloaded from NVidia (http://www.nvidia.com/Download/index.aspx?lang=en-us) or the ones that Windows installs?

Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker) This is indeed important!.

If you are using the windows drivers: Could you check if official NVidia drivers make a difference?

I will try to install that in a minute
I was talking about these drivers up to date . I think they are provided by windows but I am not sure

Just as I installed nVIDIA drivers ,and no it doesn't make any difference , still crashes....

can you use the buildbot version, without the opengl32.dll being there this time, make it crash and make a screenshot of the console window again?

I ran it 2 times and I seem to no longer get that error , but it crashes

You all gave up ? Please help...

Bastien Montagne (mont29) closed this task as Archived.Jul 12 2018, 4:28 PM
Bastien Montagne (mont29) claimed this task.

Am sorry, we appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Hello, I have the same problem suddenly, recently.
I think you have to revert to at least Nvidia Driver 377 for it to work, I remember it working there for sure sure.

I'm using

Intel CPU I7-7700HQ
Nvidia GTX 1050

Anyways I'm going to hunt down that old ass driver and tell you what I got from it

Update: It didn't work. sigh! It has to be some sort of software issue, because I didn't have this problem a couple months ago.
It might be because of a windows update? Otherwise I can't find out for the life of me what changed for this to have happened.

Update2: I was able to use the bot version, so my problem must be different. My Windows defender was preventing it from starting initially, maybe there's something to it there.

Update3: I fixed the problem by opening blender in compatability mode windows 8

Update4: Actually it opens and everything, but when i do anything in the user preferences it eventually crashes. Usually when I try to access the system tab