Combine different armatures
Closed, InvalidPublic

Description

Hello;

The problem that I live in may not be a bug. but I could not find any solution.I searched on the internet, but I could not find anything useful.

I recorded a small, quiet video Video problems start at 2 minutes

The problem is actually, I want two different Armatures to be one. Size changed when adding "hidden blade" model to Armature product group. I don't know what this problem is.

The second problem is related to moving the bones. After moving the bones, they press Alt+G (or S, R) to come back to the very beginning. I want to fix the bones of the model to the new position after moving.

for example, I move the bones of the model. I'm bringing it to a nice position. When I export, the positions of the modell bones are zeroing.
I mean, I change the position of your bone, but when I hit Alt+G you press not go back to your old position.

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Jun 25 2018, 1:18 PM

Afaics, you are parenting the blade to the existing "Armature" (which doesnt have the corresponding bones for the blade anymore -- you deleted them in 0:15 of the video)
You could actually join the imported "Armature.001" object (that came with the FBX import -- and that was working nicely) to the existing "Armature" object. Just select both Armatures and Ctrl+J

Regarding the other issues: it is hard to tell without having your .blend file here (to be able to reproduce you should upload all needed files here), but it looks like you want to move the bones in editmode [not posemode!] to define the restpose, see the manual

This doesnt really look like a bug [unless I misunderstand something], could you please check if above works for you?
If you still think you've found a bug, please upload your .blend here and exact steps to reproduce the bug...

Marking as incomplete for the time being....

Selman (TSelman61) added a comment.EditedJun 27 2018, 12:44 AM

Weights do not work when I combine just armatures. (Vertex groups)

All I have to do is press on Ctrl+A.
"Ctrl+A / Visual geometry to mesh | or(Alt+C)". In edit mode it is now in fixed position. Video

But when I add the model that I still import to the "first armature" group, the size changes. I have not found a solution to this. But it must be a solution Video

size reduction Models
...

Forget all of them :-)
I finally found the solution Final video anyway
Thank you for everything.

Bastien Montagne (mont29) claimed this task.

Definitively not a bug, user forums like blenderartists.org or blender.stackexchange.com should be used for that matter.

Also for the future, please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.
Videos and/or links to external sites etc. are not acceptable as bug report (they can be provided as additional information only).