Page MenuHome

Crash on Vector Transform node - EEVEE.
Closed, ArchivedPublic

Description

System Information
WIndows 7
Amd A4-6300
Radeon HD 8370D

Blender Version
blender-2.80.0-git.7a07500-windows64

Short description of error
When a material is setup in this configuration:

By moving the normal sphere causes blender to crash

Exact steps for others to reproduce the error
download tha attatched .blend and play arround with the Normal node sphere, eventualy and ramdomly it will crash.

Details

Type
Bug

Event Timeline

Confirmed here using 2.8-46bdbc6c78b on Windows 10, nVidia Quadro 600 1gb

I've attached the stack trace in full to the bug but the top few lines are:

blender.exe!std::_Hash<std::_Uset_traits<Gwn_Batch *,std::_Uhash_compare<Gwn_Batch *,std::hash<Gwn_Batch *>,std::equal_to<Gwn_Batch *> >,std::allocator<Gwn_Batch *>,0> >::emplace<Gwn_Batch * &>(Gwn_Batch * & <_Val_0>) Line 303 C++
blender.exe!gwn_context_add_batch(Gwn_Context * ctx, Gwn_Batch * batch) Line 166 C++
blender.exe!batch_vao_get(Gwn_Batch * batch) Line 213 C
blender.exe!GWN_batch_program_set_no_use(Gwn_Batch * batch, unsigned int program, const Gwn_ShaderInterface * shaderface) Line 295 C

LazyDodo (LazyDodo) triaged this task as Incomplete priority.Jul 4 2018, 2:28 AM

when you collapse this panel, does the problem go away?

when you collapse this panel, does the problem go away?

No but it does beave diferently.
the cube turns pink at the last moment before the crash.

might be related to T55695 , but given i can't repro, hard to say for sure.

@Jean Da Costa (jeacom256) does it still happen with latest 2.8 build? Thanks.

Bastien Montagne (mont29) closed this task as Archived.Aug 4 2018, 3:01 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.