Page MenuHome

Undo in edit mode causes a crash
Closed, ResolvedPublic

Description

System Information
Linux
renderer: 'GeForce GTX 1060 6GB/PCIe/SSE2'
vendor: 'NVIDIA Corporation'
version: '4.5.0 NVIDIA 384.130'

Blender Version
Broken: version: 2.80 (sub 20), branch: blender2.8, commit date: 2018-07-04 00:23, hash: 405c6c077f6

Short description of error
Crashing at a specific situation when undoing in edit mode.

Exact steps for others to reproduce the error
enter sculpt mode
select a tool and enable dyntopo
sculpt the object a little
enter edit mode and undo everything in queue until back in object mode
enter edit mode again and start undo a few times and blender crashes

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

yep, weird ugly things are happening here… probably due to mixing undos. @Campbell Barton (campbellbarton) think that one is for you?

2.8 have changed since this report was made.
The crashing are still happening in this very specific and odd situation but to reproduce the error now it has to be clarified in the steps above that you change to Sculpt mode through the "object interaction mode" menu at the up left corner of the screen.

The crash do not occur when reproduced in the sculpting workspace!

Campbell Barton (campbellbarton) closed this task as Resolved.EditedJan 31 2019, 6:44 AM

Some fixes have been made in this area recently so this may have been fixed too.

Closing, report a new bug with spesific steps that crash.