RGB channel problems with Cycles and TGA file format
Closed, ArchivedPublic

Description

System: Windows 10 Pro (v. 1803)
Graphic card: GeForce GTX 1080 Ti

Blender v. 2.79
Date: 2018-02-22 14:10
Hash: f4dc9f9d68b

Hi.

I have problems using RGBA channels of TGAs in Cycles. I want to use every single color channel of an TGA to work with it individually.
In my case I am writing greyscale informations into the channels, like bumpmap, anisotrophy or roughness. All in one file.

Following a shot with a simple setup show the problem. I've attached the blend file for testing too.

Cycles seem to multiply the Alpha channel informations into all other channels while rendering. But Blenders image editor shows the channels right.

EDIT: In the meantime I switched to TIFF files. TIFFs color channels can be read by single and my node tree works fine in Cycles.
But it would be good if you check it with TGAs and fix the problem for the future. There are a lot of people who are working with TGA.

Thank you
Chris

Details

Type
Bug

Hi Carlo.

Thank you for the link to T38582.

The mentioned workaround does not help me here. I need all four channels because I use one file only and can't create a seperate alpha image.
Disabling "Use Alpha" in the image doesn't help me here.

Best wishes
Chris

As the other thread mentioned:

"That's how it is intended to behave currently, if you have images with zero alpha in areas it will always be black. I can see that it is sometimes useful to separate them, but it's not supported currently. All I can suggest now is to use the alpha channel for alpha only."

I even created a patch back in the day to do the exact same thing, but its functionality was changed midway through -- https://developer.blender.org/D486

OK. But the issue is known already since four years. I hope my thread help to fix that or change it for the upcoming releases.
Softimage XSI supported seperating all channels of bitmaps already 10 years ago.

Thank you and best wishes
Chris

Brecht Van Lommel (brecht) closed this task as Archived.Mon, Jul 9, 1:02 PM