3D Viewport Bug - Ghosting of Geometry - Blender 2.8 d28d202fd1 on macOS High Sierra 10.13.5
Closed, ResolvedPublic

Description

System Information
Macbook Pro 15inch, 2017
macOS High Sierra 10.13.5
Intel Core i7 2.9GHz
Radeon Pro 560 4096 MB
Intel HD Graphics 630 1536 MB

Blender Version
Broken: 2.8 d28d202fd1 x86_64
Worked: 2.79 ;)

Short description of error
When I scroll in on an object, i. e. a cube, when I zoom back out i still see some slight silhouette of the cube blocking parts of the grid and other objects. As soon as i resize the viewport it disappears but comes back as soon as i zoom or rotate the 3D View. I attached a screencapture to elaborate.

Exact steps for others to reproduce the error
Vanilla Blender 2.8 without modifications. Regular Startup File with Eevee.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Normal priority.Jul 16 2018, 3:54 PM

Looks like a buffer refreshing issue or something… @Clément Foucault (fclem) might have a better idea of the problem, or maybe @Jeroen Bakker (jbakker) ?

Seems like Z-fighting during the TAA. Can be that the buffers are not copied correctly, but that is strange as it only uses BLIT functions.

@Martin (Strandbummler) Can you try to set the viewport quality to 0 in the user preferences. This will disable TAA and see if this helps.
Will try to reproduce it, but I don't have the hardware it is failing on.

Good morning. Unfortunately that didn't have an effect. Still the same. It only occurs in LookDev mode, in solid and rendered mode everything is fine.

@Martin (Strandbummler) You say that it only occurs in LookDev mode but your video is in Solid mode.

If you did what @Jeroen Bakker (jbakker) suggested, it affects the Solid view only.
If you want to disable the TAA for lookdev and rendered mode go to the Render Properties panel (with EEVEE as render engine) and under the sampling tab set the viewport samples to 1.

Of course, you're right. Viewport Quality affects solid mode. Check. But setting viewport samples to 1 or 0 does not work for the lookdev mode. Still the same effect.

// EDIT

Sorry, was in Cycles for the last part. Now its gone! You're right :)

Just a FYI: As a workaround, so i don't have to turn down sampling or viewport quality, i just put a big plane in the background. Its only an issue with a transparent backdrop.

on AMD Radeon R9 M395X 4096 MB (OSX iMac 5k) the proposed Viewport Samples and viewport quality "fixes" the issue.
However in Eevee Render Preview and enabled screen(space)_subsurface_scattering, viewport still acts up.

For the record the culprit function might be GPU_framebuffer_blit.

It breaks TAA in workbench (solid view) and Eevee as well as Eeevee Subsurface because they all use this function.

@Roel Koster (kostex) Are you sure this glitch happen with the AMD GPU?

@Roel Koster (kostex) this does not indicate the graphic card used by OpenGL.

To know that, use Help menu > Save System Info.
Then search for the Opengl renderer string.

That's what you get when dealing with noobs ;-) Sorry..

But the OpenGL Renderer is in fact AMD.. is it not? I don't dare to conclude anything anymore ;-)

I attached mine too. Since GPU Rendering, at least with cycles, is broken since for ever on the mac, i always thought blender is running sole on CPU. Who knew.

So seems you are both using the AMD card. So there is a similar problem on the intel 630 on windows reported by other users.

I also have the same issue as mentioned above. On an iMac5K with AMD Radeon Pro 580.

Hello my subject was connected to this one.
WIN 10 processor intel I3 7300 HD graphics 630
last driver win64_24.20.100.6194
blender-2.80-8f01623ef31-win64
yesterday I tried the new version and now I get something normal in solid view
but with EEVEE and cycles the same issue in material view (lookdev) and render view
Open GL is ok in material view
I tried the different setting in viewportsampling to 1 and viewport quality to 0 > no change

As of right now, Intel Integrated Graphics users are having the black ghosting affect in the Eevee render mode as well. The workbench is working fine, and cycles works fine, but Eevee does not. It has been a bug for some time now, but we havent had a proper means to report it, although it does technically lead to a crash if one tries to edit materials while in the Eevee renderer. A lot of us are eager to use Eevee, as it seems to be an extremely valuable asset, we are not able to though because of this bug.

As far as I have heard, its affecting a wide range of different Integrated Graphics cards from Intel. For instance, mine is a 530, but as stated above, the 630 is also having the issue. @Clément (clempi)

I'm guessing that the Intel thing isn't as high of a priority as others, which is understandable. Just really makes testing Eevee hard when one cant actually use Eevee. As of right now, the main reason I'm not using blender is because Intel users can't use the Eevee render engine (nor material preview in both Cycles and Eevee) because it's broken for Integrated graphics cards.

@Vincent Lovett (OathOfPosidon) It's not that it is a lower priority issue it's just that it's hard to debug this particular issue without access to the hardware. But I found someone who has the same issue and live nearby so I will fix this ASAP.

@Clément Foucault (fclem) Thank you for the work that you are doing, I'm sorry if my previous comment came off as demanding or anything, because it wasn't. I really do appreciate you caring enough to look into, and fix, the bug.

Good evening gentlemen. Is there any news on this issue? Right now it's the one thing keeping me from really getting into 2.8. I just compiled again, but the bug still persists.

Thanks :)

Because of this planes viewed in orto arent't visable, unless you're in edit-mode

Orfeo (onic) added a subscriber: Orfeo (onic).EditedOct 2 2018, 1:00 PM

If I set the Viewport Quality to 0.000 the ghosting is gone

Blender 2.80 Alpha 2 (2018-09-30)
MacBook Pro (15-inch, 2017)
macOS Mojave 10.14

This works for me!

Blender 2.8 Alpha 2 (2018-09-29)
iMac 27" (2017)
macOS Mojave 10.14

zgorg (zgorg) added a comment.EditedOct 3 2018, 2:33 PM

video to show the situation now on HD630
1rst October version
https://www.youtube.com/watch?v=dG-6Cfb-jFE

viewport is at 0
and when I close preferences window > crash
even if I want to open fullscreen

it's working! the very last update of my graphic card HDgraphics630 helps
a bug with contact shadow[[ https://www.dropbox.com/s/zkjhviqrjonu7bm/Blender.jpg?dl=0 | artefact on the left ]]
other user of HD graphics, what are your settings?

but I have some little black points on my surface and I don't know why

Clément Foucault (fclem) closed this task as Resolved.Fri, Nov 9, 12:13 PM
Clément Foucault (fclem) claimed this task.

I think we fixed this issue for everyone now. Closing.

yes it's working. big job. I had hope a such work in the interface. but it's not so sure about that...for instance modifications in keys are strange and often useless! I have to restored shift C cursor to center, ctrl alt shit c set origin. I added shift RMB to move cursor and shift alt RMB to move it on surfaces ^^ it's already possible in the key configuration. why not present in their tool menu. border select have a bug in object mode: it doesn't add several selections. it's cool to work on such mysterious keys like alt E to add several color in the ramp node but there is more logical things to do first. ctrl t and alt t back! no way. why all this is still present but was substract from the settings. ctrl u is back no way...
and in the interface if they don't understand how much faster is a crtl t I dont have to explain many other things...