Crash within a few tries of attempting to render the scene with EEVEE and Freestyle enabled
Closed, ResolvedPublic

Description

System Information
Windows 10 Pro 64 bit (1803)
AMD Radeon RX480 4GB with Radeon Software 18.7.1

Blender Version
Broken: Latest Blender 2.8 build with Visual Studio 2017 (7c8e6048b3a95c9c5ca2902da4511c6453e14973)

Short description of error
Blender crashes when attempting to render the image with the Eevee rendering engine and Freestyle is enabled.

This does not necessarily happen right away, but within a few tries the program eventually crashes with the following generic error from the command line:

Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF74E8388A5
Module  : d:\blender-git\build_windows__x64_vc15_Release\bin\Release\blender.exe

Exact steps for others to reproduce the error

  1. Load factory settings
  2. Properties > Render > Freestyle [Enable]
  3. Hit F12 to render
  4. Within 1 to several tries, Blender crashes

Additional notes
Does not appear to crash when Cycles is the default renderer.
I realize that Freestyle in general does not support Eevee correctly yet.

Details

Type
Bug

Cannot reproduce the crash here with linux (debian64 testing)… :/

To make sure I wasn't having problem with my building environment, I tried to download the latest Windows 64bit build from Buildbot as of writing (git20180716 dc3b3d94538).

After repeating the above procedure (load factory settings, enable Freestyle, F12 render) I still managed to eventually reproduce the bug. However, in one instance it required several tries, and in another one Blender didn't appear to crash within a reasonable number of tries (but it did after restarting the program). In a last attempt it crashed right away.

It could be a GPU vendor-specific issue. What GPU are you using? I just tried again with the latest buildbot build, and it crashed on the first attempt, by the way.

Furthermore, when it does not crash, all I'm getting a black screen render (but with Cycles, Freestyle works correctly). I previously assumed that this functionality is simply not working in general with EEVEE, but perhaps it's a related GPU-specific bug? I didn't report it due to the bug tracker currently being open only for crashes.

What GPU are you using?

Quadro FX 1800

I'm getting a black screen render

If you check the Z-Buffer you should see the cube.

I previously assumed that this functionality is simply not working in general with EEVEE...

Yeah, not implemented yet.


Upon further testing I managed to get it to crash.
After tweaking the line thickness and running --debug
I got this:

add freestyle
Uniform 'utilTex' not found!
Uniform 'shadowCubeTexture' not found!
Uniform 'shadowCascadeTexture' not found!
Uniform 'maxzBuffer' not found!
Uniform 'horizonBuffer' not found!
Uniform 'irradianceGrid' not found!
Uniform 'probeCubes' not found!
Uniform 'probePlanars' not found!

But when i don't run --debug it works fine...

Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 26 2018, 10:25 AM

Could be a lot of things, but would suspect some OpenGL issue… Can you please run it with --debug-gpu option and attach as text file here any error printed out in the console (do not paste it directly in comment)? Thanks. Also maybe worth trying with -t 1 option (to run in single-thread mode).

@fcelm, maybe you have better ideas about what to try here?

@Bastien Montagne (mont29)
This time I even used a debug build, quickly obtaining a crash within 1-2 attempts of rendering the image with Freestyle enabled, as of e91bdb10e9c. Note that it says RX580 but it's actually an RX480 (there should be no difference OpenGL-wise; this is due to a GPU modification).

Console output with --debug-gpu --factory-startup

Console output with --debug-gpu --factory-startup -t 1

Also attached:

As of Blender 2.8 f08f6c1adec I'm not able to reproduce the above issue anymore (with a release build). Freestyle still doesn't get rendered correctly with EEVEE (F12 render shows a black screen), but I guess that's to be expected at this stage.

Bastien Montagne (mont29) closed this task as Resolved.Aug 9 2018, 11:29 AM
Bastien Montagne (mont29) claimed this task.

Eeeeh ok, then I guess we can close as solved. :)

s12a (s12a) added a comment.EditedAug 9 2018, 11:42 AM

As I went to confirm that this bug got resolved I found that F12 rendering now doesn't work at all (Blender doesn't crash, but it freezes and must be forcibly closed), either with release or debug builds, and regardless of whether Freestyle is enabled or not. This only happens when EEVEE is the active Render engine.

However this is a different bug.