Uniform errors and memory leak using Material Previews
Closed, ResolvedPublic

Description

Windows 10 64 Bits. - Blender 2.8 branch
NVDIA GTX660
Source compiled with VS2017 at 17/07/2018 22:00

  1. Start blender with: blender.exe --factory-startup --debug
  2. Select default cube.
  3. Select default material tab in properties panel.
  4. Open Preview panel.
  5. Close Blender.

The log here: P753

I have checked that memory leak is only when use preview panel.

Details

Type
Bug

@Clément Foucault (fclem) I think this one is for you.

Let me know if I can help you.

It seems to have happened with a change from today (17th July) because I could reproduce only after updating my local repo with todays commits.

Can you try to bisect this?

Yes, I'm going to try to find the exact commit.

The error was introduced in commit 644fadf2f0131f8ecd73da6c994ec8a8d4b0a7d1

Bastien Montagne (mont29) triaged this task as Confirmed priority.Thu, Jul 26, 10:30 AM
Bastien Montagne (mont29) closed this task as Resolved.

Seems like it was fixed in rB057b4a6acf97 ;)