Blender 2.79 - New Despgraph - Animation gets out of sync when dealing with visibility.
Closed, ArchivedPublic

Description

System Information
Linux x64 Ubuntu 17.10

Blender Version
Broken: b85be88655c

Short description of error
Animation gets out of sync when dealing with visibility.

Exact steps for others to reproduce the error

  1. Start blender with new despgraph and blank scene. Add a cube
  2. set frame to frame 1
  3. insert keyframe on visibility on both render & viewport via outliner
  4. set frame to frame 10
  5. toggle visibility on both render & viewport via outliner
  6. insert keyframe on visibility on both render and viewport via outliner
  7. set frame to frame 1
  8. insert keyframe on location by hovering over the location in the N toolbar and pressing i
  9. press up arrow to jump to frame 10
  10. click & drag the Z location in the N toolbar to the left to change the location on the z axis, i moved it ~1m
  11. hover over the locations in the n tool bar and press i
  12. click drag in the timeline between frames 1 and 10 and notice how it doesnt move

Details

Type
Bug

Would someone be able to confirm this bug please?

Bastien Montagne (mont29) triaged this task as Incomplete priority.Thu, Jul 26, 11:16 AM

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

Also please try with blender2.8 build, that the reference one for new depsgraph. ;)

Carlo Andreacchio (candreacchio) raised the priority of this task from Incomplete to Needs Triage.EditedThu, Jul 26, 12:44 PM

EDIT: I tried to make a blend file and though it summarised the problem. seems like I can only provide a blank scene to ensure this bug is seen in a consistant manner. Can you please tell me which of hte steps I listed out are not precise enough? I can provide a blank blender scene if required, but it seems pretty pointless.

In regards to blender 2.8. It is not possible to animate blender2.8 viewport visibility which means I am unable to confirm whether this also effects blender2.8. It would be great to get this fixed in blender 2.79

Bastien Montagne (mont29) closed this task as Archived.Thu, Jul 26, 5:01 PM
Bastien Montagne (mont29) claimed this task.

Welll then… will archive for now. Am sorry, but 2.79 won’t get any new fixes (especially not regarding non-finalized features like new depsgraph), so if this is not reproducible in 2.8 there is no point to keep it open really. Thanks for the report anyway.