Page MenuHome

Crash when selecting bone in editmode using mouse
Closed, ResolvedPublic

Description

System Information
Windows 10 64bit
NVIDIA GeForce GTX 1060 6GB

Blender Version
blender-2.80.0-git.f07140940c4-windows32

Short description of error
crash when selecting the only bone with right click in edit mode

Exact steps for others to reproduce the error

As in the video I uploaded:
create new armature -> go to edit mode -> Right click on the bone

The crash doesnt occur when selecting the bone with 'A' key

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) triaged this task as Confirmed priority.Jul 23 2018, 11:20 AM

Confirmed 9df1e54079344ed4e2becef9e57cf1b925b46dff - NVidia Geforce GT 740M

  • batch->elem == NULL
  • Crashes on if (el->use_prim_restart) {
>	blender.exe!GPU_batch_draw_range_ex(GPUBatch * batch, int v_first, int v_count, bool force_instance) Line 622	C
 	blender.exe!draw_geometry_execute_ex(DRWShadingGroup * shgroup, GPUBatch * geom, unsigned int start, unsigned int count, bool draw_instance) Line 847	C
 	blender.exe!draw_geometry_execute(DRWShadingGroup * shgroup, GPUBatch * geom) Line 855	C
 	blender.exe!draw_shgroup(DRWShadingGroup * shgroup, DRWState pass_state) Line 1129	C
 	blender.exe!drw_draw_pass_ex(DRWPass * pass, DRWShadingGroup * start_group, DRWShadingGroup * end_group) Line 1234	C
 	blender.exe!workbench_deferred_draw_scene(WORKBENCH_Data * vedata) Line 852	C
 	blender.exe!workbench_solid_draw_scene(void * vedata) Line 74	C
 	blender.exe!drw_engines_draw_scene() Line 981	C
 	blender.exe!DRW_draw_render_loop_ex(Depsgraph * depsgraph, RenderEngineType * engine_type, ARegion * ar, View3D * v3d, GPUViewport * viewport, const bContext * evil_C) Line 1466	C
 	blender.exe!DRW_draw_view(const bContext * C) Line 1351	C
 	blender.exe!view3d_main_region_draw(const bContext * C, ARegion * ar) Line 1282	C
 	blender.exe!ED_region_do_draw(bContext * C, ARegion * ar) Line 494	C
 	blender.exe!wm_draw_window_offscreen(bContext * C, wmWindow * win, bool stereo) Line 539	C
 	blender.exe!wm_draw_window(bContext * C, wmWindow * win) Line 667	C
 	blender.exe!wm_draw_update(bContext * C) Line 824	C
 	blender.exe!WM_main(bContext * C) Line 478	C
 	blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 527	C
Joshua Leung (aligorith) renamed this task from 2.8 Crash bone selection to Crash when selecting bone in editmode using mouse.Jul 23 2018, 11:21 AM

This crash seems to be fixed in blender-2.80-ab49b7d7396-win64

Jurek (solartistic) closed this task as Resolved.Tue, Dec 4, 1:29 PM
Jurek (solartistic) claimed this task.