Page MenuHome

OpenColorIO Error when adding Material to Object in New Scene
Closed, ResolvedPublic

Description

System Information
OS: Arch Linux,
Graphics Card: GTX 1060

Blender Version
2.79b

Short description of error
This message repeats in the console repeatedly after adding a material to an object in a new scene:

OpenColorIO Error: DisplayTransform error. Cannot find display colorspace,  ''.

Exact steps for others to reproduce the error

  1. Open a new instance of blender
  2. Create a new scene
  3. (Click the "+" button at the right of the Scene selector at the top of the 3D View
  4. Inside "Scene.001" in the 3D view, add a cube and give that cube a material.
  5. Observe the console showing the repeated error message:

    OpenColorIO Error: DisplayTransform error. Cannot find display colorspace, ''.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.Jul 30 2018, 11:54 AM
Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.Oct 29 2018, 4:26 PM

@Daniel Oakey (doakey3), Can not reproduce the issue.. Do you use some sort of custom OCIO configuration? What does the color management settings of the new scene show?

When I tested this on my windows computer, the issue did not occur. This only seems to happen on my linux machine. I guess I don't know what a custom OCIO configuration is. I'm using the XFCE desktop environment on Arch linux.

Just to add to this, I see the problem in 2.8 when I take these steps...

  • Compile 2.8 ( in Visual Studio, or using the make command line tool ) : NOTE - the same latest build from the Blender website works OK
  • Load blender / default scene
  • Go into Eevee Rendered mode
  • Create new scene

Blender will now crash.

I've attached a screenshot showing the call stack when compiled and ran in debug mode, just in case that helps... ( the crash happens in release mode too in my locally built version )

If you want me to try anything at my end to try to narrow down the issue ( if you're not seeing the same thing on your own computers ), just let me know!

( Windows 10, GTX 1070 - I noticed that the original author has a 1060 )

On Mac OS 10.13, recent nightly build of Blender 2.79, I'm having the same problem.

Despite the complaint, images do render, however.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.Nov 22 2018, 12:51 PM

Can confirm the issue here with both 2.7x and 2.8 builds. Seems to be a problem between display device (set to DCI-P3 for new scenes for some reason)…

@Sergey Sharybin (sergey) either we stick to default startup display device in BKE_color_managed_display_settings_init(), instead of calling IMB_colormanagement_display_get_default_name(), or we change BKE_color_managed_view_settings_init() to set proper a valid value for current display_device…

I'm still getting this crash in the latest build.

  1. Go into Eevee Rendered mode
  2. Select "New scene" from the Scene dropdown in the top right

or do it in the other order...

  1. Select "New scene" from the Scene dropdown in the top right
  2. Go into Eevee Rendered mode
Sergey Sharybin (sergey) closed this task as Resolved.Dec 5 2018, 2:12 PM

I've done series of changes in this area, which solves this bug.

For those who are interested: rBb927d196969, rB6122e1d6c02.

Thanks for the report, closing it now.