Page MenuHome

It’s impossible to make a Track To Constraint looking at Z or -Z
Closed, ArchivedPublic

Description

Please rename my username to mandarajo3d, thanks.

System Information
Windows 10 64-bit
NVIDIA GeForce 840M

Blender Version
Broken: 2.79b

Short description of error
It’s impossible to make a Track To Constraint looking at Z or -Z

Exact steps for others to reproduce the error
It's impossible to make a Track To Constraint looking at Z or -Z? Look at the gif below, when the Empty is on the Z axis then the animation looks so weird.


If you download the file, the problem happen at frame 38.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but that’s called gimbal lock, a universal issue with Euclidian rotations, nothing we can do about it and not a bug, just known limitation.