Page MenuHome

Blender crash used Grease Pencil
Closed, ResolvedPublic

Description

System Information
Window 7, amd rodeon r7200

Blender Version
Blender 2.8 Hash: ab49b7d7396
Worked: (optional)

Short description of error
when i selcwt object Grease Pencil and then selecting mode "Draw" the program close

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

System
FreeBSD 11.2 amd64

blender version
branch blender2.8 hash 503866c68154

I can add an empty grease pencil object and as I draw I see the stroke but when I release the mouse it disappears. Adding a suzanne grease pencil object crashes. Annotations work.

* thread #1, name = 'blender', stop reason = signal SIGSEGV: invalid address (fault address: 0x20)
    frame #0: 0x00000008156e5530 libc.so.7`strcmp + 96
libc.so.7`strcmp:
->  0x8156e5530 <+96>:  movb   (%rdi), %al
    0x8156e5532 <+98>:  incq   %rdi
    0x8156e5535 <+101>: movb   (%rsi), %dl
    0x8156e5537 <+103>: incq   %rsi
(lldb) bt
* thread #1, name = 'blender', stop reason = signal SIGSEGV: invalid address (fault address: 0x20)
  * frame #0: 0x00000008156e5530 libc.so.7`strcmp + 96
    frame #1: 0x0000000000cbaaa0 blender`gpencil_monkey_color + 96
    frame #2: 0x0000000000cba33f blender`ED_gpencil_create_monkey + 111
    frame #3: 0x0000000000c86f10 blender`object_gpencil_add_exec + 448
    frame #4: 0x0000000000a3189e blender`wm_operator_invoke + 510
    frame #5: 0x0000000000a2c54d blender`wm_operator_call_internal + 381
    frame #6: 0x0000000000beeacb blender`ui_apply_but_funcs_after + 235
    frame #7: 0x0000000000bead1d blender`ui_popup_handler + 589
    frame #8: 0x0000000000a322ce blender`wm_handlers_do_intern + 1006
    frame #9: 0x0000000000a2e84f blender`wm_handlers_do + 31
    frame #10: 0x0000000000a2db91 blender`wm_event_do_handlers + 993
    frame #11: 0x0000000000a28b10 blender`WM_main + 32
    frame #12: 0x0000000000a24db3 blender`main + 979
    frame #13: 0x0000000000a247c4 blender`_start + 148

woops.. I got in too quick.

I get the above crash when starting blender2.80 with a previously saved startup config and workbenches, starting with --factory-startup works fine.

Antonio Vazquez (antoniov) closed this task as Resolved.Aug 2 2018, 9:37 AM
Antonio Vazquez (antoniov) claimed this task.

What was meant to resolve this, I don't see any change, now using 777e1b9654ca

Sorry, I missunderstood the message above and thought it was solved.

Today, we have done a change in how the context is managed and maybe is related to your error. 503866c68154

Could you try blender --factory-startup to check if the error appears?

If does not work, please try tomorrow build to see if your error is related to the other errors.

A funcionado restaurando de fábrica el programa. No encuentro las paletas de colores, supongo que no se ha implementado. La versión Grease Pencil 2.8 Branch del 21 de marzo subida a la pagina GraphicAll.org tiene una interfaz bastante intuitiva, espero que se pueda volver a implementar esta ideas sobre esta versión.

commit 503866c68154 was what I reported the crash on. Just checked again with 45751065c0e1 - same. I'm also not 100% sure my crash is same as original reporter.

Yes factory startup works right but having previous saved 2.80 startup crashes when using new GP object.

Annotations in all views work fine. New grease pencil objects don't, I can add an empty GP and drawing appears but disappears after releasing mouse, adding a GP monkey object crashes as above.

Just tested, by using a 2.79 startup and no crash, I guess if it is only caused by an early 2.80 alpha startup file, then maybe we could ignore my crash.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 3 2018, 9:51 AM

@Federico Barroso (zarco1794) The palette colors has been replaced with materials (see: https://code.blender.org/2018/07/grease-pencil-status-update/ for more info)

As the error is only if you use old user prefs, could we consider this bug as solved?

For me, the problem has been solved