Page MenuHome

Crashing from copying bone properties
Closed, ResolvedPublic

Description

System Information
Ubuntu Mate 16.04 GeForce GTX 580

Blender Version
Broken: branch: blender2.8, commit date: 2018-08-01 23:26, hash: ab49b7d7396

Short description of error
Blender crash

Exact steps for others to reproduce the error
Select a bone in pose mode. Go to bone properties. if I do Ctrl+C 2 times while hovering over "Bone Group" or "Custom Object" then blender crash (always on the second time when doing ctrl + c)

Details

Type
Bug

Event Timeline

s12a (s12a) added a subscriber: s12a (s12a).EditedAug 4 2018, 11:55 AM

I cannot open the provided file on both 2.79b and 2.80 alpha (on Windows 10 x64-1803).
A smaller, simpler file might be better to show the issue.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Indeed…
Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

I have reproduced the bug.

System Information
Windows 10
Radeon RX 460

Blender Version
Broken: 2.80.21 7b1fec463e

Short description of error
Blender crash when hit Ctrl + C twice on "Bone Group" or "Custom Object".

Exact steps for others to reproduce the error

  1. Add an armature
  2. Enter pose mode
  3. Move mouse cursor on "Bone Group" or "Custom Object" in Bone tab in Properties panel
  4. Hit Ctrl + C twice

Cannot reproduce here on linux with latest branch. Please add .blend file as already requested!

I could reproduce on 2018-08-13 13:25, Hash aac5458fa58 on Windows 10 Pro x64 (1803) and AMD Radeon RX580 4GB with Radeon Software 18.8.1, and I have provided a .blend file along with other information with a debug build.



Basically you have to open the .blend, hover the cursor over "Bone Group" or "Custom Object" in Bone tab in Properties panel as @Kinouti Takahiro (dskjal) suggests and hit Ctrl+C twice.

The important part is doing this while the cursor is hovering the text input area.

Sorry for the late reply I was in vacation :D

System Information
Ubuntu 16.04
GeForce GTX 580

Blender Version
blender2.8, commit date: 2018-08-12 05:22, hash: 4b6fa4d897a

Exact steps for others to reproduce the error

  1. I've created a rig using rigify in blender 2.79
  2. Move mouse cursor on "Bone Group" or "Custom Object" in Bone tab in Properties panel
  3. Hit Ctrl + C twice

The same problem happened to me before also in the modifiers

I could reproduce on commit date: 2018-08-13 14:53 Hash 0e8bd6ba8a, windows 10 x64 RX460 and Debian 9.4 Celeron G3930 iGPU.

This is a record.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Thanks, confirmed, will check.

@Campbell Barton (campbellbarton) issue is in ui_textedit_end(), which frees but->search_arg… I cannot understand why that is done, sounds totally wrong to me, that kind of thing should only be freed by but_free imho? Removing that freeing does fix the issue in any case.

Brecht Van Lommel (brecht) closed this task as Resolved.

Confirm crash in rB0e8bd6ba8a, but appears solved in latest master.