Page MenuHome

The materials look wrong in windows 10
Closed, ArchivedPublic

Description

System Information

PC: TECLAST X5 Pro
SO: Microsoft Windows 10 Home (64-bit) and Ubuntustudio-18.04-dvd-amd64
Processor: Intel® Core™ m3-7Y30
Graphics: Intel® HD Graphics 615
RAM: 8 Gb
SSD: Teclast 256GB NS550-2242

Blender Versions

blender-2.80.0-git.ccf794dfc4c-windows64
blender-2.80-1ae77fe9c1f-linux-glibc219-x86_64

Short description of error:

With the same computer, the materials look good in linux and wrong in windows 10

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Most certainly a driver issue… Please:

  • Give us your exact Blender, OS and GPU (including drivers) versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker or open source ones in linux distributions).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Attach as text file here the report generated by Help -> System Info (do not paste it directly in comment).
  • Launch Blender from the command line with --debug-gpu option and attach as text file here any error printed out in the console (do not paste it directly in comment).

Ok ... Detailed System Report ...

With the same computer, the materials look good in linux and wrong in windows 10...

blender-2.80.0-git.ccf794dfc4c-windows64

  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker or open source ones in linux distributions).

I think you're a bit confused with the drivers situation on linux,
especially for gpu amd and intel only open source drivers now exist, these are the official supported drivers and are in continuous development ....

already on another bug report I had made a careful review on the situation with the drivers amd linux, I asked if it was possible to investigate what was the problem to be able to report it to mesa drivers developers and you have archived the report

My drivers are the latest offered by the Intel update system.

UbuntuStudio Live from SD it does not fail.
Windows 10 with the latest intel drivers it fails if you apply materials in Cycles, Evee looks better. The problem is when you start applying materials.

My drivers are the latest offered by the Intel update system.
UbuntuStudio Live from SD it does not fail.

on linux they work well because the mesa open source drivers intel on ubuntu 18.04 now easily support opengl 4.5

In Windows 10 it also supports OpenGL 4.5 and even Vulkan, but visualization problems still exist. Now you have done something because EVEE or CYCLES did not work for me before. Now EVEE lets me sculp, what fails me is CYCLES...

@Lucas Torrón López (asimetrix) Can you upload your blend? I'm experiencing similar situation with Intel HD 520 with Eevee displaying black and Windows 10 driver is supposed to support OpenGL 4.5.

I have problems with windows 10 with linux (UbuntuStudio) no problems. It happens to me with all the files in general, when I apply materials to them. With Evee I can see for modeling, my problem is when I apply materials, with all the files, the example file is this ...

Confirm the same issue with Intel HD 520 on Windows 10.

This image shows the same black area.

With intel and windows some very strange things happen. If the problem is intel, they need to optimize their graphics to Blender as they do with many video games.

Charlie, I'm sure if you try that Blender with Linux you're doing fine.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

@Clément Foucault (fclem) tagging you here just in case, but imho that’s clearly driver issue, we cannot really keep hundreds of tasks opened on things we cannot do anything about, so will archive. Thanks for the report anyway.

I remember this was working on previous builds of 2.8 so I think it's not drivers.

I don't have access to a computer that can reproduce the issue but I will in a few weeks.

I remember this was working on previous builds of 2.8 so I think it's not drivers.

Confirm, something changed during code quest that broke Workbench. That is working again on Intel HD 520 but Eevee is broken.

If there is anything I can do to help please ask.

Thanks Clément. I have this issue in a Microsoft Surface 4, i5 with 4Gb RAM. The GPU is an Intel HD Graphics 520.
Hope it helps :)

The basic visualization for modeling and matcaps is going well, the problem continues in this date when you apply materials.